aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTaylor C. Richberger <taywee@gmx.com>2017-12-25 22:49:30 -0700
committerGitHub <noreply@github.com>2017-12-25 22:49:30 -0700
commit365c0cad14aa194dfa5cf68caca3cc20c7d39076 (patch)
tree5391d4b0e55b25d4c909ff4e816dcb742132cf2f /CMakeLists.txt
parentreplace explicit std::vector ParseCLI with template, reduce optimization (diff)
parentadd more test cases (diff)
downloadargs.hxx-365c0cad14aa194dfa5cf68caca3cc20c7d39076.tar.xz
Merge pull request #56 from pavel-belikov/bash-completion
Bash completion
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 322e8d1..d0aaa69 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,14 @@ add_executable(argstest-multiple-inclusion test/multiple_inclusion_1.cxx test/mu
target_link_libraries(argstest-multiple-inclusion args)
set_property(TARGET argstest-multiple-inclusion PROPERTY CXX_STANDARD 11)
+add_executable(gitlike examples/gitlike.cxx)
+target_link_libraries(gitlike args)
+set_property(TARGET gitlike PROPERTY CXX_STANDARD 11)
+
+add_executable(completion examples/completion.cxx)
+target_link_libraries(completion args)
+set_property(TARGET completion PROPERTY CXX_STANDARD 11)
+
enable_testing()
add_test(NAME "test" COMMAND argstest)
add_test(NAME "test-multiple-inclusion" COMMAND argstest-multiple-inclusion)