aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPavel Belikov <pavel.fuchs.belikov@gmail.com>2017-11-06 22:34:17 +0300
committerPavel Belikov <pavel.fuchs.belikov@gmail.com>2017-11-06 22:34:17 +0300
commitb55cd27c082d8c6fcbaf98e7b2fbd17140e71801 (patch)
tree9090ce66117e26c99f5b248393533dc5170995dd /CMakeLists.txt
parentMerge pull request #38 from pavel-belikov/subparsers-help (diff)
downloadargs.hxx-b55cd27c082d8c6fcbaf98e7b2fbd17140e71801.tar.xz
add travis ci, appveyor, coveralls
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..dfcbaa0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright (c) 2016-2017 Taylor C. Richberger <taywee@gmx.com> and Pavel
+# Belikov
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to
+# deal in the Software without restriction, including without limitation the
+# rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+# sell copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+cmake_minimum_required(VERSION 3.2)
+project(args CXX)
+
+add_library(args INTERFACE)
+target_include_directories(args INTERFACE "${CMAKE_CURRENT_SOURCE_DIR}")
+
+add_executable(argstest test.cxx)
+target_link_libraries(argstest args)
+set_property(TARGET argstest PROPERTY CXX_STANDARD 11)
+
+if (MSVC)
+ target_compile_options(argstest PRIVATE /W4 /WX)
+else ()
+ target_compile_options(argstest PRIVATE -Wall -Wextra -Werror -pedantic -Wshadow -Wunused-parameter)
+endif ()
+
+enable_testing()
+add_test(NAME "test" COMMAND argstest)