aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTaylor C. Richberger <taywee@gmx.com>2017-11-26 09:41:51 -0700
committerGitHub <noreply@github.com>2017-11-26 09:41:51 -0700
commit8c32aefd61e259a4a8dde7eee1252accd4c63372 (patch)
treec15d9be9c6a252cbb14b81a653582358e1e810e1 /CMakeLists.txt
parentMerge pull request #44 from pavel-belikov/better-value-parsing (diff)
parenttrigger travis ci (diff)
downloadargs.hxx-8c32aefd61e259a4a8dde7eee1252accd4c63372.tar.xz
Merge pull request #48 from pavel-belikov/fix-multiple-inclusion
Fix inclusion into multiple source files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81864d7..322e8d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,5 +35,10 @@ else ()
target_compile_options(argstest PRIVATE -Wall -Wextra -Werror -pedantic -Wshadow -Wunused-parameter)
endif ()
+add_executable(argstest-multiple-inclusion test/multiple_inclusion_1.cxx test/multiple_inclusion_2.cxx)
+target_link_libraries(argstest-multiple-inclusion args)
+set_property(TARGET argstest-multiple-inclusion PROPERTY CXX_STANDARD 11)
+
enable_testing()
add_test(NAME "test" COMMAND argstest)
+add_test(NAME "test-multiple-inclusion" COMMAND argstest-multiple-inclusion)