aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build37
1 files changed, 0 insertions, 37 deletions
diff --git a/meson.build b/meson.build
deleted file mode 100644
index 2966733..0000000
--- a/meson.build
+++ /dev/null
@@ -1,37 +0,0 @@
-project('glitch kernel', 'c', version: '0.0.0', default_options: ['c_std=gnu11', 'warning_level=2', 'b_coverage=true'])
-
-cc = meson.get_compiler('c')
-if(cc.has_argument('-fanalyzer'))
- add_project_arguments('-fanalyzer', language: 'c')
-endif
-python3 = import('python').find_installation('python3')
-qemu = find_program('qemu-system-i386')
-
-conf = configuration_data()
-conf.set_quoted('VERSION', run_command(['git', 'describe', '--long'], capture: true, check: true).stdout().strip())
-conf.set_quoted('CC', cc.get_id() + ' ' + cc.version())
-configure_file(output: 'conf.h', configuration: conf)
-
-subdir('arch/i686')
-subdir('devices')
-subdir('lib')
-
-kernel = executable('glitch.elf',
- ['src/multiboot2.c', 'src/mmap.c', 'src/kernel.c',
- 'src/isr.c', 'src/mem/vmm.c'],
- link_with: [libk],
- link_language: 'c',
- link_args: ['-static', '-T', meson.current_source_dir()/'arch/i686/linker.ld'],
- install: true, native: false, override_options: ['b_coverage=false'],
- include_directories: [
- include_directories('grub/include', is_system: true),
- include_directories('lib')
- ],
- dependencies: [arch, devices]
-)
-
-glitch_iso = custom_target('glitch.iso',
- input: 'scripts/mkiso.py', output: 'glitch.iso', depends: [kernel],
- command: [python3, '@INPUT@', kernel, '@SOURCE_ROOT@/grub/grub.cfg'])
-
-run_target('run', depends: glitch_iso, command: [qemu, '-cdrom', 'glitch.iso', '-accel', 'kvm'])