aboutsummaryrefslogtreecommitdiff
path: root/meson/compiler_flags/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/compiler_flags/meson.build')
-rw-r--r--meson/compiler_flags/meson.build34
1 files changed, 0 insertions, 34 deletions
diff --git a/meson/compiler_flags/meson.build b/meson/compiler_flags/meson.build
deleted file mode 100644
index f159eb4..0000000
--- a/meson/compiler_flags/meson.build
+++ /dev/null
@@ -1,34 +0,0 @@
-# global compiler settings
-common_compiler_flags = [
- '-Wshadow',
- '-Wunused', '-Wunused-parameter',
- '-Wmisleading-indentation',
- '-Wundef',
- '-Wuninitialized',
- # casts
- '-Wcast-align', # performance problem casts
- '-Wcast-qual',
- # conversion
- '-Wconversion', # type conversion may lose data
- '-Wsign-conversion', # sign conversion
- '-Wdouble-promotion', # implicit float to double
- # pointers
- '-Wpointer-arith',
- '-Wnull-dereference',
-]
-c_compiler_flags = [
- '-fanalyzer',
-]
-cpp_compiler_flags = [
- '-Weffc++',
- # inheritance
- '-Wnon-virtual-dtor', # class with virtual functions has non-virt dtor
- '-Woverloaded-virtual', # overloaded (not override) virtual function
- # casts
- '-Wold-style-cast', # C-style casts
-]
-add_project_arguments(common_compiler_flags, c_compiler_flags, language: 'c')
-add_project_arguments(common_compiler_flags, cpp_compiler_flags, language: 'cpp')
-add_project_arguments('-D__ARCH__=i686', language: 'c', native: false)
-
-subdir_done()