summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3848ca1..e943900 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,17 +14,18 @@ license=('BSD-3clause')
depends=()
optdepends=()
makedepends=('git' 'make')
-options=('staticlibs' '!strip')
-source=("git+https://chromium.googlesource.com/breakpad/breakpad")
conflicts=('google-breakpad-svn' 'google-breakpad-git')
-sha512sums=('SKIP')
+options=('staticlibs' '!strip')
+source=("git+https://chromium.googlesource.com/breakpad/breakpad"
+ "git+https://chromium.googlesource.com/linux-syscall-support")
+sha512sums=('SKIP' 'SKIP')
prepare() {
cd $srcdir/breakpad/src/third_party
- if [ ! -f lss/linux_syscall_support.h ]; then
+ if [ ! -d lss/ ]; then
mkdir lss
- curl -L https://chromium.googlesource.com/linux-syscall-support/+/master/linux_syscall_support.h?format=TEXT | base64 --decode > lss/linux_syscall_support.h
fi
+ cp $srcdir/linux-syscall-support/linux_syscall_support.h lss/linux_syscall_support.h
}
pkgver() {