summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-11-16 21:49:47 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2019-11-16 21:49:47 +0200
commitd42c5d686d7b5842226c812a9ec82d99111e15d0 (patch)
tree7bd99cfd39421500e7c3c51085fc5d0d4434d6fa
downloaddeclarativewidgets-git-master.tar.xz
Initial commitHEADmaster
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..1ffc9cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Aqua-sama <aqua@iserlohn-fortress.net>
+
+pkgname=DeclarativeWidgets-git
+pkgver=r322.4126c30
+pkgrel=1
+pkgdesc="Library and tools for creating QtWidget UIs using QML"
+url="https://github.com/KDAB/DeclarativeWidgets"
+license=('GPL')
+arch=('x86_64')
+depends=(qt5-declarative)
+makedepends=(qt5-tools)
+source=("git+https://github.com/KDAB/DeclarativeWidgets")
+md5sums=('SKIP')
+
+pkgver() {
+ cd DeclarativeWidgets
+ echo r$(git rev-list --count HEAD)-$(git rev-parse --short HEAD) | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd DeclarativeWidgets
+ qmake -r declarativewidgets.pro
+ make
+}
+
+package() {
+ cd DeclarativeWidgets
+ INSTALL_ROOT="$pkgdir" make install
+}