summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-17 21:26:33 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-17 21:26:33 -0700
commit36bf70ac02979784d2d7114cbbf82420c727edf6 (patch)
tree14b15919f336d06cfd9f5485ac9a9c2813e13f54
parentDisable debug settings that are a ramhog to build (diff)
downloadlinux-ck-36bf70ac02979784d2d7114cbbf82420c727edf6.tar.xz
Updated to 5.6.3
Removed obsolete bdver2 patch
-rw-r--r--PKGBUILD16
-rw-r--r--graysky_bdver2-hotfix.patch11
2 files changed, 5 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d579a37..cc7d269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# # I maintain this because:
# Arch version patch script does not apply consistently
-# Arch version lacks graysky gcc patch with bdver2 fix
+# Arch version lacks graysky gcc patch
# Arch version lacks ath9k regdom and raid6 algo patches
# Arch version lacks ck patches
# Arch version is 300 Hz
@@ -21,8 +21,8 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=7
-_minver=2
-_gccpatchver='20200527'
+_minver=3
+_gccpatchver='20200615'
_gccpatchger='10.1'
_gccpatchker='5.7'
_ckpatchversion=ck1
@@ -47,7 +47,6 @@ source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
- graysky_bdver2-hotfix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
raid6-default-algo.patch
@@ -60,12 +59,11 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('94a8e3411b397615aedbd258cb5613121be9b0f353e49c4959108ae7785574a88aa2ae4a283177331654fa4454fd68b94bb05e79db7fa1e12422f45b431a7c9f'
+b2sums=('476d625d77e202e8b00b78605f313ee3649c35ba7ade7e374e51b835daa25b7ebc0f3e85a58d2c82d5d3b771e526e0e5e15cfd41a7be76fb4df8083854eec92b'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
'29b2530e91a7c0f75c47d75361a94ec92fec398cef1b3e213e97c8f9e0ed210711c4c63ae7717f59273105a83e30397cbd5b7252cb94c06d9b328a24c70ad444'
- '76137504bd6eb54b9aa1eb3f3d78ec60b80d607d0554ba5ec60431db2b62963354e1461b57a8de4f89d4399ef7f66041c6b2366b5d9fd53d5f9857a9dabd4188'
- 'c8a52c056ecaeba55bee0b17c6a264d460792694e883b5654b8c1694b376a25be4aff1e6b86b5e3486c6e3adfc2062f805e91a9cac1156d0104d7e781028bec6'
+ 'c8d0697f99fe6105815217b8ec059d8f587415ea8dd2b88a65e1087feedf697341a64cd56810fde9e7aeada79125fc8235faccc7e7b06492c099e27a8abbe99c'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
'bce4fd3a790c9937fd0db02b9cd9fcb9c2f364c2694441c7ce45a65a163a40870a56d02fcddd6b1a63e03e76cec203a649570949cc4ddc8f18f3e08e22801be7'
@@ -103,10 +101,6 @@ prepare() {
patch -Np1 -i ../unscrew-ck1.patch
- # graysky gcc hotfixes
- echo "Applying graysky gcc patch hotfixes"
- patch -p1 -i ../graysky_bdver2-hotfix.patch "$srcdir/kernel_gcc_patch-${_gccpatchver}/enable_additional_cpu_optimizations_for_gcc_v${_gccpatchger}+_kernel_v${_gccpatchker}+.patch"
-
# graysky gcc patch
echo "Applying graysky cpu patch"
patch -p1 -i ../kernel_gcc_patch-${_gccpatchver}/enable_additional_cpu_optimizations_for_gcc_v${_gccpatchger}+_kernel_v${_gccpatchker}+.patch
diff --git a/graysky_bdver2-hotfix.patch b/graysky_bdver2-hotfix.patch
deleted file mode 100644
index 0b3e809..0000000
--- a/graysky_bdver2-hotfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/kernel_gcc_patch-20200527/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.5-v5.6.patch
-+++ b/kernel_gcc_patch-20200527/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.5-v5.6.patch
-@@ -492,7 +492,7 @@
- + cflags-$(CONFIG_MBOBCAT) += $(call cc-option,-march=btver1)
- + cflags-$(CONFIG_MJAGUAR) += $(call cc-option,-march=btver2)
- + cflags-$(CONFIG_MBULLDOZER) += $(call cc-option,-march=bdver1)
--+ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2)
-++ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2) $(call cc-option,-mno-tbm)
- + cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-march=bdver3)
- + cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-march=bdver4)
- + cflags-$(CONFIG_MZEN) += $(call cc-option,-march=znver1)