summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-11 22:50:29 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-11 22:50:29 -0700
commit616e56a87957562d15a4ec41b7ffe48de7a987e3 (patch)
treec4239b171c17eaf79a2c32c58541bdad98a3c362
parentUpdated to 5.7.1 (diff)
downloadlinux-ck-616e56a87957562d15a4ec41b7ffe48de7a987e3.tar.xz
Updated to 5.7.2
Applied hotfix
-rw-r--r--PKGBUILD11
-rw-r--r--unscrew-ck1.patch31
2 files changed, 39 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07e6e28..eb3c21d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=7
-_minver=1
+_minver=2
_gccpatchver='20200527'
_gccpatchger='10.1'
_gccpatchker='5.7'
@@ -53,13 +53,14 @@ source=(
raid6-default-algo.patch
config # the main kernel config file
sphinx-workaround.patch
+ unscrew-ck1.patch::https://github.com/ckolivas/linux/commit/0b69e633d6b0b08ae8547dc4099c8c0985019553.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('db92398c10b9e609e833851638901a63e84d2e6fe13ded17ebfe27c3c14e12df8f846ca08e649c18d9f61ea3ca51b6a0e86cce14484ddb91091f3a5dabd642cb'
+b2sums=('94a8e3411b397615aedbd258cb5613121be9b0f353e49c4959108ae7785574a88aa2ae4a283177331654fa4454fd68b94bb05e79db7fa1e12422f45b431a7c9f'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
'29b2530e91a7c0f75c47d75361a94ec92fec398cef1b3e213e97c8f9e0ed210711c4c63ae7717f59273105a83e30397cbd5b7252cb94c06d9b328a24c70ad444'
@@ -68,7 +69,8 @@ b2sums=('db92398c10b9e609e833851638901a63e84d2e6fe13ded17ebfe27c3c14e12df8f846ca
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
'0adb22724c00e3edc44baa75b61af07dad119da81fe152d04c62dfd4d1eb4314862059dccb1768aff0b2e7194b78a73d6783328ed207885ddcd79081e4d37bbe'
- 'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95')
+ 'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95'
+ '84c9438120100bb5b21122a29344b9e818514d94a31b6d57519a6e25385cb7f91a7f87c930da55c828c7a4330959a94b8a3a3d56773c46b335e1380cd00180b1')
#export KBUILD_BUILD_HOST=arc4linux
export KBUILD_BUILD_USER=$pkgbase
@@ -96,6 +98,9 @@ prepare() {
# ck patch
echo "Applying ck patch"
patch -F 3 -Np1 -i ../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}
+
+ # ck hotfix
+ patch -Np1 -i ../unscrew-ck1.patch
# graysky gcc hotfixes
diff --git a/unscrew-ck1.patch b/unscrew-ck1.patch
new file mode 100644
index 0000000..67e87c8
--- /dev/null
+++ b/unscrew-ck1.patch
@@ -0,0 +1,31 @@
+From 0b69e633d6b0b08ae8547dc4099c8c0985019553 Mon Sep 17 00:00:00 2001
+From: Con Kolivas <kernel@kolivas.org>
+Date: Thu, 11 Jun 2020 21:48:56 +1000
+Subject: [PATCH] Fix cpufreq_cooling build.
+
+---
+ kernel/sched/MuQSS.c | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/kernel/sched/MuQSS.c b/kernel/sched/MuQSS.c
+index 18a9b4a23e44e..c55c158e8b8e4 100644
+--- a/kernel/sched/MuQSS.c
++++ b/kernel/sched/MuQSS.c
+@@ -3246,6 +3246,17 @@ static inline u64 do_task_delta_exec(struct task_struct *p, struct rq *rq)
+ return ns;
+ }
+
++DEFINE_PER_CPU(unsigned long, thermal_pressure);
++
++void arch_set_thermal_pressure(struct cpumask *cpus,
++ unsigned long th_pressure)
++{
++ int cpu;
++
++ for_each_cpu(cpu, cpus)
++ WRITE_ONCE(per_cpu(thermal_pressure, cpu), th_pressure);
++}
++
+ /*
+ * Return accounted runtime for the task.
+ * Return separately the current's pending runtime that have not been