summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-07-09 14:18:44 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-07-09 14:18:44 -0700
commit7a0fc4dcb27a18a7315251c374d696fdd1dd66ba (patch)
treec7e287f322fee19ddb09a59f448b80fcfee0e73a
parentUpdated to 5.7.7 (diff)
downloadlinux-ck-7a0fc4dcb27a18a7315251c374d696fdd1dd66ba.tar.xz
Updated to 5.7.8
-rw-r--r--0003-ALSA-usb-audio-Fix-packet-size-calculation.patch35
-rw-r--r--0003-Revert-ath9k-Fix-general-protection-fault.patch199
-rw-r--r--0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch42
-rw-r--r--0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch30
-rw-r--r--PKGBUILD16
5 files changed, 237 insertions, 85 deletions
diff --git a/0003-ALSA-usb-audio-Fix-packet-size-calculation.patch b/0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
deleted file mode 100644
index b75ab48..0000000
--- a/0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 17c5f7dd425becd30c4a2dafaecb054641a1fdc9 Mon Sep 17 00:00:00 2001
-From: Alexander Tsoy <alexander@tsoy.me>
-Date: Mon, 29 Jun 2020 05:59:33 +0300
-Subject: ALSA: usb-audio: Fix packet size calculation
-
-Commit f0bd62b64016 ("ALSA: usb-audio: Improve frames size computation")
-introduced a regression for devices which have playback endpoints with
-bInterval > 1. Fix this by taking ep->datainterval into account.
-
-Note that frame and fps are actually mean packet and packets per second
-in the code introduces by the mentioned commit. This will be fixed in a
-follow-up patch.
-
-Fixes: f0bd62b64016 ("ALSA: usb-audio: Improve frames size computation")
-BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=208353
-Signed-off-by: Alexander Tsoy <alexander@tsoy.me>
----
- sound/usb/endpoint.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/sound/usb/endpoint.c b/sound/usb/endpoint.c
-index 9bea7d3f99f8..11f23778f0a5 100644
---- a/sound/usb/endpoint.c
-+++ b/sound/usb/endpoint.c
-@@ -1093,6 +1093,7 @@ int snd_usb_endpoint_set_params(struct snd_usb_endpoint *ep,
- ep->freqn = get_usb_high_speed_rate(rate);
- ep->fps = 8000;
- }
-+ ep->fps >>= ep->datainterval;
-
- ep->sample_rem = rate % ep->fps;
- ep->framesize[0] = rate / ep->fps;
---
-cgit v1.2.3-1-gf6bb5
-
diff --git a/0003-Revert-ath9k-Fix-general-protection-fault.patch b/0003-Revert-ath9k-Fix-general-protection-fault.patch
new file mode 100644
index 0000000..5c7a1fa
--- /dev/null
+++ b/0003-Revert-ath9k-Fix-general-protection-fault.patch
@@ -0,0 +1,199 @@
+From 1a32e7b57b0b37cab6845093920b4d1ff94d3bf4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Viktor=20J=C3=A4gersk=C3=BCpper?=
+ <viktor_jaegerskuepper@freenet.de>
+Date: Wed, 1 Jul 2020 23:32:28 +0200
+Subject: Revert "ath9k: Fix general protection fault in ath9k_hif_usb_rx_cb"
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This reverts commit 2bbcaaee1fcb ("ath9k: Fix general protection fault
+in ath9k_hif_usb_rx_cb") because the driver gets stuck like this:
+
+ [ 5.778803] usb 1-5: Manufacturer: ATHEROS
+ [ 21.697488] usb 1-5: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
+ [ 21.701377] usbcore: registered new interface driver ath9k_htc
+ [ 22.053705] usb 1-5: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
+ [ 22.306182] ath9k_htc 1-5:1.0: ath9k_htc: HTC initialized with 33 credits
+ [ 115.708513] ath9k_htc: Failed to initialize the device
+ [ 115.708683] usb 1-5: ath9k_htc: USB layer deinitialized
+
+Reported-by: Roman Mamedov <rm@romanrm.net>
+Ref: https://bugzilla.kernel.org/show_bug.cgi?id=208251
+Fixes: 2bbcaaee1fcb ("ath9k: Fix general protection fault in ath9k_hif_usb_rx_cb")
+Tested-by: Viktor Jägersküpper <viktor_jaegerskuepper@freenet.de>
+Signed-off-by: Viktor Jägersküpper <viktor_jaegerskuepper@freenet.de>
+---
+ drivers/net/wireless/ath/ath9k/hif_usb.c | 48 ++++++++------------------------
+ drivers/net/wireless/ath/ath9k/hif_usb.h | 5 ----
+ 2 files changed, 11 insertions(+), 42 deletions(-)
+
+diff --git a/drivers/net/wireless/ath/ath9k/hif_usb.c b/drivers/net/wireless/ath/ath9k/hif_usb.c
+index 4ed21dad6a8e..6049d3766c64 100644
+--- a/drivers/net/wireless/ath/ath9k/hif_usb.c
++++ b/drivers/net/wireless/ath/ath9k/hif_usb.c
+@@ -643,9 +643,9 @@ err:
+
+ static void ath9k_hif_usb_rx_cb(struct urb *urb)
+ {
+- struct rx_buf *rx_buf = (struct rx_buf *)urb->context;
+- struct hif_device_usb *hif_dev = rx_buf->hif_dev;
+- struct sk_buff *skb = rx_buf->skb;
++ struct sk_buff *skb = (struct sk_buff *) urb->context;
++ struct hif_device_usb *hif_dev =
++ usb_get_intfdata(usb_ifnum_to_if(urb->dev, 0));
+ int ret;
+
+ if (!skb)
+@@ -685,15 +685,14 @@ resubmit:
+ return;
+ free:
+ kfree_skb(skb);
+- kfree(rx_buf);
+ }
+
+ static void ath9k_hif_usb_reg_in_cb(struct urb *urb)
+ {
+- struct rx_buf *rx_buf = (struct rx_buf *)urb->context;
+- struct hif_device_usb *hif_dev = rx_buf->hif_dev;
+- struct sk_buff *skb = rx_buf->skb;
++ struct sk_buff *skb = (struct sk_buff *) urb->context;
+ struct sk_buff *nskb;
++ struct hif_device_usb *hif_dev =
++ usb_get_intfdata(usb_ifnum_to_if(urb->dev, 0));
+ int ret;
+
+ if (!skb)
+@@ -751,7 +750,6 @@ resubmit:
+ return;
+ free:
+ kfree_skb(skb);
+- kfree(rx_buf);
+ urb->context = NULL;
+ }
+
+@@ -797,7 +795,7 @@ static int ath9k_hif_usb_alloc_tx_urbs(struct hif_device_usb *hif_dev)
+ init_usb_anchor(&hif_dev->mgmt_submitted);
+
+ for (i = 0; i < MAX_TX_URB_NUM; i++) {
+- tx_buf = kzalloc(sizeof(*tx_buf), GFP_KERNEL);
++ tx_buf = kzalloc(sizeof(struct tx_buf), GFP_KERNEL);
+ if (!tx_buf)
+ goto err;
+
+@@ -834,9 +832,8 @@ static void ath9k_hif_usb_dealloc_rx_urbs(struct hif_device_usb *hif_dev)
+
+ static int ath9k_hif_usb_alloc_rx_urbs(struct hif_device_usb *hif_dev)
+ {
+- struct rx_buf *rx_buf = NULL;
+- struct sk_buff *skb = NULL;
+ struct urb *urb = NULL;
++ struct sk_buff *skb = NULL;
+ int i, ret;
+
+ init_usb_anchor(&hif_dev->rx_submitted);
+@@ -844,12 +841,6 @@ static int ath9k_hif_usb_alloc_rx_urbs(struct hif_device_usb *hif_dev)
+
+ for (i = 0; i < MAX_RX_URB_NUM; i++) {
+
+- rx_buf = kzalloc(sizeof(*rx_buf), GFP_KERNEL);
+- if (!rx_buf) {
+- ret = -ENOMEM;
+- goto err_rxb;
+- }
+-
+ /* Allocate URB */
+ urb = usb_alloc_urb(0, GFP_KERNEL);
+ if (urb == NULL) {
+@@ -864,14 +855,11 @@ static int ath9k_hif_usb_alloc_rx_urbs(struct hif_device_usb *hif_dev)
+ goto err_skb;
+ }
+
+- rx_buf->hif_dev = hif_dev;
+- rx_buf->skb = skb;
+-
+ usb_fill_bulk_urb(urb, hif_dev->udev,
+ usb_rcvbulkpipe(hif_dev->udev,
+ USB_WLAN_RX_PIPE),
+ skb->data, MAX_RX_BUF_SIZE,
+- ath9k_hif_usb_rx_cb, rx_buf);
++ ath9k_hif_usb_rx_cb, skb);
+
+ /* Anchor URB */
+ usb_anchor_urb(urb, &hif_dev->rx_submitted);
+@@ -897,8 +885,6 @@ err_submit:
+ err_skb:
+ usb_free_urb(urb);
+ err_urb:
+- kfree(rx_buf);
+-err_rxb:
+ ath9k_hif_usb_dealloc_rx_urbs(hif_dev);
+ return ret;
+ }
+@@ -910,21 +896,14 @@ static void ath9k_hif_usb_dealloc_reg_in_urbs(struct hif_device_usb *hif_dev)
+
+ static int ath9k_hif_usb_alloc_reg_in_urbs(struct hif_device_usb *hif_dev)
+ {
+- struct rx_buf *rx_buf = NULL;
+- struct sk_buff *skb = NULL;
+ struct urb *urb = NULL;
++ struct sk_buff *skb = NULL;
+ int i, ret;
+
+ init_usb_anchor(&hif_dev->reg_in_submitted);
+
+ for (i = 0; i < MAX_REG_IN_URB_NUM; i++) {
+
+- rx_buf = kzalloc(sizeof(*rx_buf), GFP_KERNEL);
+- if (!rx_buf) {
+- ret = -ENOMEM;
+- goto err_rxb;
+- }
+-
+ /* Allocate URB */
+ urb = usb_alloc_urb(0, GFP_KERNEL);
+ if (urb == NULL) {
+@@ -939,14 +918,11 @@ static int ath9k_hif_usb_alloc_reg_in_urbs(struct hif_device_usb *hif_dev)
+ goto err_skb;
+ }
+
+- rx_buf->hif_dev = hif_dev;
+- rx_buf->skb = skb;
+-
+ usb_fill_int_urb(urb, hif_dev->udev,
+ usb_rcvintpipe(hif_dev->udev,
+ USB_REG_IN_PIPE),
+ skb->data, MAX_REG_IN_BUF_SIZE,
+- ath9k_hif_usb_reg_in_cb, rx_buf, 1);
++ ath9k_hif_usb_reg_in_cb, skb, 1);
+
+ /* Anchor URB */
+ usb_anchor_urb(urb, &hif_dev->reg_in_submitted);
+@@ -972,8 +948,6 @@ err_submit:
+ err_skb:
+ usb_free_urb(urb);
+ err_urb:
+- kfree(rx_buf);
+-err_rxb:
+ ath9k_hif_usb_dealloc_reg_in_urbs(hif_dev);
+ return ret;
+ }
+diff --git a/drivers/net/wireless/ath/ath9k/hif_usb.h b/drivers/net/wireless/ath/ath9k/hif_usb.h
+index 5985aa15ca93..a94e7e1c86e9 100644
+--- a/drivers/net/wireless/ath/ath9k/hif_usb.h
++++ b/drivers/net/wireless/ath/ath9k/hif_usb.h
+@@ -86,11 +86,6 @@ struct tx_buf {
+ struct list_head list;
+ };
+
+-struct rx_buf {
+- struct sk_buff *skb;
+- struct hif_device_usb *hif_dev;
+-};
+-
+ #define HIF_USB_TX_STOP BIT(0)
+ #define HIF_USB_TX_FLUSH BIT(1)
+
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch b/0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
deleted file mode 100644
index 2cce397..0000000
--- a/0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 7fab9d4206e54d19b578c70cd0529045ad642f25 Mon Sep 17 00:00:00 2001
-From: Nicholas Kazlauskas <nicholas.kazlauskas@amd.com>
-Date: Mon, 29 Jun 2020 13:03:52 -0400
-Subject: drm/amd/display: Only revalidate bandwidth on medium and fast updates
-
-[Why]
-Changes that are fast don't require updating DLG parameters making
-this call unnecessary. Considering this is an expensive call it should
-not be done on every flip.
-
-[How]
-Guard the validation to only happen if update type isn't FAST.
-
-Signed-off-by: Nicholas Kazlauskas <nicholas.kazlauskas@amd.com>
----
- drivers/gpu/drm/amd/display/dc/core/dc.c | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/drivers/gpu/drm/amd/display/dc/core/dc.c b/drivers/gpu/drm/amd/display/dc/core/dc.c
-index 4acaf4be8a81..c825d383f0f1 100644
---- a/drivers/gpu/drm/amd/display/dc/core/dc.c
-+++ b/drivers/gpu/drm/amd/display/dc/core/dc.c
-@@ -2533,10 +2533,12 @@ void dc_commit_updates_for_stream(struct dc *dc,
-
- copy_stream_update_to_stream(dc, context, stream, stream_update);
-
-- if (!dc->res_pool->funcs->validate_bandwidth(dc, context, false)) {
-- DC_ERROR("Mode validation failed for stream update!\n");
-- dc_release_state(context);
-- return;
-+ if (update_type > UPDATE_TYPE_FAST) {
-+ if (!dc->res_pool->funcs->validate_bandwidth(dc, context, false)) {
-+ DC_ERROR("Mode validation failed for stream update!\n");
-+ dc_release_state(context);
-+ return;
-+ }
- }
-
- commit_planes_for_stream(
---
-cgit v1.2.3-1-gf6bb5
-
diff --git a/0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch b/0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch
new file mode 100644
index 0000000..598403c
--- /dev/null
+++ b/0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch
@@ -0,0 +1,30 @@
+From 2fadccbdd143a95db9ba06110261142c9bb2acbd Mon Sep 17 00:00:00 2001
+From: Alessio Bonfiglio <alessio.bonfiglio@mail.polimi.it>
+Date: Thu, 2 Jul 2020 17:05:52 +0200
+Subject: iwlwifi: Make some Killer Wireless-AC 1550 cards working again
+
+Fix the regression introduced by commit c8685937d07f ("iwlwifi: move pu devices to new table") by add the ids and the configurations of two missing Killer 1550 cards in order to make these cards being configured and working correctly again (following the new table convention).
+Resolve bug 208141 ("Wireless ac 9560 not working kernel 5.7.2", https://bugzilla.kernel.org/show_bug.cgi?id=208141).
+
+Fixes: c8685937d07f ("iwlwifi: move pu devices to new table")
+Signed-off-by: Alessio Bonfiglio <alessio.bonfiglio@mail.polimi.it>
+---
+ drivers/net/wireless/intel/iwlwifi/pcie/drv.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
+index 29971c25dba4..9ea3e5634672 100644
+--- a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
++++ b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
+@@ -577,6 +577,8 @@ static const struct iwl_dev_info iwl_dev_info_table[] = {
+ IWL_DEV_INFO(0x30DC, 0x1552, iwl9560_2ac_cfg_soc, iwl9560_killer_1550i_name),
+ IWL_DEV_INFO(0x31DC, 0x1551, iwl9560_2ac_cfg_soc, iwl9560_killer_1550s_name),
+ IWL_DEV_INFO(0x31DC, 0x1552, iwl9560_2ac_cfg_soc, iwl9560_killer_1550i_name),
++ IWL_DEV_INFO(0xA370, 0x1551, iwl9560_2ac_cfg_soc, iwl9560_killer_1550s_name),
++ IWL_DEV_INFO(0xA370, 0x1552, iwl9560_2ac_cfg_soc, iwl9560_killer_1550i_name),
+
+ IWL_DEV_INFO(0x271C, 0x0214, iwl9260_2ac_cfg, iwl9260_1_name),
+
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/PKGBUILD b/PKGBUILD
index 5ba8f91..f21f2e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=7
-_minver=7
+_minver=8
_gccpatchver='20200615'
_gccpatchger='10.1'
_gccpatchker='5.7'
@@ -47,8 +47,8 @@ source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
- 0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
- 0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
+ 0003-Revert-ath9k-Fix-general-protection-fault.patch
+ 0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
@@ -62,12 +62,12 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('0bd13b75dba824231903ce5542936c911661b5fe54f565cfb3fc31cde96d1557d543367f232fac8c8ecec65a065dd843bd7a55fb67d9dd8abfae3074808520c7'
+b2sums=('e586d51ea94a35a1f5f3801d478752a8b873a815bfcbb332eb36293ff101e88c8d10978f06831f12d5ca6df02e54368cca6f66ae9dcf7befc01358954fa8cb29'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
'490c7d188215f1d24b5807a744853fa308c2cd17c9eb8668918a50a0c58cab9cbc9ee13ac9abbb614eb010a4a56e9092fea4440d44c80c8e67f2d9abdf19a83f'
- 'c080582b285af6b08f004e49ff4b96a074ad455b91688bc06a96bd6cfe422e6d270e7157f95cb7ad9a6b0fd47e07f2b1ec06f7f275591d22c958de4077a28b87'
- '49ddc76376ec49e099089d7f87e5f566524ccf1b1ac7acf8353a3f0a4abdd1ee1108b99860f99fd0f55cfcd8c1149fb9aa2467449ebff2cb251b8466349b95bc'
+ '35b1ace7c6d9f1c78caf6007d5500d1c5762af887cd45fddb4d32fcc289c0e0ad62473417ba4cd617f2632533a85ecadd08556cb6c106e06686cd53cc018bbef'
+ 'a0f3b060d344746d7cd02b9b8b0f6e13a4367d41aa92ef7db4b6d01d2a0389b63da3e19484ac809952ef6ee13479a54ad205017c9ead72c4ee6738ae04cb7c4b'
'29b2530e91a7c0f75c47d75361a94ec92fec398cef1b3e213e97c8f9e0ed210711c4c63ae7717f59273105a83e30397cbd5b7252cb94c06d9b328a24c70ad444'
'c8d0697f99fe6105815217b8ec059d8f587415ea8dd2b88a65e1087feedf697341a64cd56810fde9e7aeada79125fc8235faccc7e7b06492c099e27a8abbe99c'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
@@ -94,8 +94,8 @@ prepare() {
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
patch -p1 -i ../0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
- patch -p1 -i ../0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
- patch -p1 -i ../0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
+ patch -p1 -i ../0003-Revert-ath9k-Fix-general-protection-fault.patch
+ patch -p1 -i ../0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch
patch -p1 -i ../sphinx-workaround.patch