summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-12 02:51:51 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-06-12 02:51:51 -0700
commitf112ef7c7de4187e5fe0b7edd559e56b22da7c3c (patch)
tree9b66b3130fc068bd951505619260fe4f6c021bb0
parentUpdated to 5.7.2 (diff)
downloadlinux-ck-f112ef7c7de4187e5fe0b7edd559e56b22da7c3c.tar.xz
Disable debug settings that are a ramhog to build
-rw-r--r--PKGBUILD11
-rw-r--r--config4
2 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb3c21d..d579a37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ url='https://kernel.org'
arch=(x86_64)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole
+ bc kmod libelf
)
conflicts=('linux-libre-ck')
options=('!strip')
@@ -68,7 +68,7 @@ b2sums=('94a8e3411b397615aedbd258cb5613121be9b0f353e49c4959108ae7785574a88aa2ae4
'c8a52c056ecaeba55bee0b17c6a264d460792694e883b5654b8c1694b376a25be4aff1e6b86b5e3486c6e3adfc2062f805e91a9cac1156d0104d7e781028bec6'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
- '0adb22724c00e3edc44baa75b61af07dad119da81fe152d04c62dfd4d1eb4314862059dccb1768aff0b2e7194b78a73d6783328ed207885ddcd79081e4d37bbe'
+ 'bce4fd3a790c9937fd0db02b9cd9fcb9c2f364c2694441c7ce45a65a163a40870a56d02fcddd6b1a63e03e76cec203a649570949cc4ddc8f18f3e08e22801be7'
'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95'
'84c9438120100bb5b21122a29344b9e818514d94a31b6d57519a6e25385cb7f91a7f87c930da55c828c7a4330959a94b8a3a3d56773c46b335e1380cd00180b1')
@@ -196,7 +196,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ #make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -273,8 +274,8 @@ _package-headers() {
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- echo "Stripping vmlinux..."
- strip -v $STRIP_STATIC "$builddir/vmlinux"
+ #echo "Stripping vmlinux..."
+ #strip -v $STRIP_STATIC "$builddir/vmlinux"
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
diff --git a/config b/config
index 667e587..a23952f 100644
--- a/config
+++ b/config
@@ -10226,11 +10226,9 @@ CONFIG_DEBUG_BUGVERBOSE=y
#
# Compile-time checks and compiler options
#
-CONFIG_DEBUG_INFO=y
+# CONFIG_DEBUG_INFO is not set
# CONFIG_DEBUG_INFO_REDUCED is not set
# CONFIG_DEBUG_INFO_SPLIT is not set
-CONFIG_DEBUG_INFO_DWARF4=y
-CONFIG_DEBUG_INFO_BTF=y
# CONFIG_GDB_SCRIPTS is not set
# CONFIG_ENABLE_MUST_CHECK is not set
CONFIG_FRAME_WARN=2048