summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-11-20 11:16:25 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-11-20 11:16:25 -0800
commitfd5aa0c32f316b6013215ae37e4b931c59ff2af4 (patch)
treecaae01aa62a87578c36339244e55a8d58dd24865
parentUpdated to 5.9.8 (diff)
downloadlinux-ck-fd5aa0c32f316b6013215ae37e4b931c59ff2af4.tar.xz
Updated to 5.9.9
-rw-r--r--0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch67
-rw-r--r--PKGBUILD11
2 files changed, 74 insertions, 4 deletions
diff --git a/0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch b/0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch
new file mode 100644
index 0000000..f29b2bc
--- /dev/null
+++ b/0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch
@@ -0,0 +1,67 @@
+From b2e41088d2a2b3dd99f268833d8079d1a98ee3ea Mon Sep 17 00:00:00 2001
+From: Sathish Narasimman <nsathish41@gmail.com>
+Date: Thu, 29 Oct 2020 13:18:21 +0530
+Subject: Bluetooth: Fix: LL PRivacy BLE device fails to connect
+
+When adding device to white list the device is added to resolving list
+also. It has to be added only when HCI_ENABLE_LL_PRIVACY flag is set.
+HCI_ENABLE_LL_PRIVACY flag has to be tested before adding/deleting devices
+to resolving list. use_ll_privacy macro is used only to check if controller
+supports LL_Privacy.
+
+https://bugzilla.kernel.org/show_bug.cgi?id=209745
+
+Fixes: 0eee35bdfa3b ("Bluetooth: Update resolving list when updating whitelist")
+Signed-off-by: Sathish Narasimman <sathish.narasimman@intel.com>
+Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
+---
+ net/bluetooth/hci_request.c | 12 ++++++++----
+ 1 file changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/net/bluetooth/hci_request.c b/net/bluetooth/hci_request.c
+index e0269192f2e5..a565c91b8599 100644
+--- a/net/bluetooth/hci_request.c
++++ b/net/bluetooth/hci_request.c
+@@ -698,7 +698,8 @@ static void del_from_white_list(struct hci_request *req, bdaddr_t *bdaddr,
+ cp.bdaddr_type);
+ hci_req_add(req, HCI_OP_LE_DEL_FROM_WHITE_LIST, sizeof(cp), &cp);
+
+- if (use_ll_privacy(req->hdev)) {
++ if (use_ll_privacy(req->hdev) &&
++ hci_dev_test_flag(req->hdev, HCI_ENABLE_LL_PRIVACY)) {
+ struct smp_irk *irk;
+
+ irk = hci_find_irk_by_addr(req->hdev, bdaddr, bdaddr_type);
+@@ -732,7 +733,8 @@ static int add_to_white_list(struct hci_request *req,
+ return -1;
+
+ /* White list can not be used with RPAs */
+- if (!allow_rpa && !use_ll_privacy(hdev) &&
++ if (!allow_rpa &&
++ !hci_dev_test_flag(hdev, HCI_ENABLE_LL_PRIVACY) &&
+ hci_find_irk_by_addr(hdev, &params->addr, params->addr_type)) {
+ return -1;
+ }
+@@ -750,7 +752,8 @@ static int add_to_white_list(struct hci_request *req,
+ cp.bdaddr_type);
+ hci_req_add(req, HCI_OP_LE_ADD_TO_WHITE_LIST, sizeof(cp), &cp);
+
+- if (use_ll_privacy(hdev)) {
++ if (use_ll_privacy(hdev) &&
++ hci_dev_test_flag(hdev, HCI_ENABLE_LL_PRIVACY)) {
+ struct smp_irk *irk;
+
+ irk = hci_find_irk_by_addr(hdev, &params->addr,
+@@ -812,7 +815,8 @@ static u8 update_white_list(struct hci_request *req)
+ }
+
+ /* White list can not be used with RPAs */
+- if (!allow_rpa && !use_ll_privacy(hdev) &&
++ if (!allow_rpa &&
++ !hci_dev_test_flag(hdev, HCI_ENABLE_LL_PRIVACY) &&
+ hci_find_irk_by_addr(hdev, &b->bdaddr, b->bdaddr_type)) {
+ return 0x00;
+ }
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/PKGBUILD b/PKGBUILD
index 0794f5f..fa95153 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,8 +21,8 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=9
-_minver=8
-_gccpatchver='20200615'
+_minver=9
+_gccpatchver='20201113'
_gccpatchger='10.1'
_gccpatchker='5.8'
_ckpatchversion=ck1
@@ -47,6 +47,7 @@ _srcname=linux-${pkgver}
source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ 0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
@@ -59,11 +60,12 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('27b8820bbd7ea278b47e1c208efeeb41c890276ae59d33971ab0d8ba0081d45e57c579f9390c5e3019a4f3beebaf17a29a959e1b6cadb9e1824ea4e568f90205'
+b2sums=('39a9a7438d8399d4e4b863e725b1b5a1ddda0c0b8b02f9fc9a4153f6dbd2ed267aaa6acaac5c0b80c8e3c122c240a82458079fcf83d639047c6372d109b2b4fe'
'SKIP'
'c1e9177debee553e03873dff9293e7a21a53297fc4b3df8b9f54a8839cf1c7d6803945fc7d64676fe8c04cb54ef331b59c4348fbc9915060162177be503d9e96'
+ '647c9a8580f3f716e39e0bc086acff1fc34d3592011c931c8e00259c395cdd7fff94d71b963cd87850b8e0f67dd31b719ce4f1cc855e553e42a5694ff6bd53dc'
'c19099ad66168db4608dee44e1913c07c035bc002a91267abc2e1eadf1788ddb5be3b17e3fdfeddcba96526dfa2b9fcc43a5dd0f8236d94c864e6477924a6718'
- 'c8d0697f99fe6105815217b8ec059d8f587415ea8dd2b88a65e1087feedf697341a64cd56810fde9e7aeada79125fc8235faccc7e7b06492c099e27a8abbe99c'
+ '7f1eb5938472f57748216bd00e0c875feab99fc1c5cb89babfea467ee30ca5c8e9fc5a691efe2e602bef1ea79820c5383822d7cec354b48d23321ccda8ee8127'
'b6ef77035611139fa9a6d5b8d30570e2781bb4da483bb569884b0bd0129b62e0b82a5a6776fefe43fee801c70d39de1ea4d4c177f7cedd5ac135e3c64f7b895a'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
'580e6966d14b14c6e21d31e9d74066d9d65f2bd83e9f4b9140dd8f5bd3c7e28e5318c7f85ccde5c70275968f9c182b8587f3de78c8a28fcb81943318cc8523bf'
@@ -86,6 +88,7 @@ prepare() {
# Hotfixes
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ patch -p1 -i ../0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch
patch -p1 -i ../sphinx-workaround.patch