summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2021-02-28 09:58:57 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2021-02-28 10:03:21 +0200
commit84f7e4490c0c86e27b8e212a21a070eefe3d3667 (patch)
treea8c6611829d28e675e785f27b0cbe8359d1b6a0f
parentUpdated to 5.11.0 (diff)
downloadlinux-ck-84f7e4490c0c86e27b8e212a21a070eefe3d3667.tar.xz
Update to 5.11.2
-rw-r--r--0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch50
-rw-r--r--0002-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch (renamed from 0003-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch)0
-rw-r--r--0003-drm-amdgpu-fix-shutdown-with-s0ix.patch (renamed from 0004-drm-amdgpu-fix-shutdown-with-s0ix.patch)0
-rw-r--r--PKGBUILD25
4 files changed, 11 insertions, 64 deletions
diff --git a/0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch b/0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch
deleted file mode 100644
index d1e59b0..0000000
--- a/0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 66b6d6c8306329134abeeb26d352f2074b2f0e1e Mon Sep 17 00:00:00 2001
-From: Hui Wang <hui.wang@canonical.com>
-Date: Mon, 8 Feb 2021 13:02:37 +0800
-Subject: Bluetooth: btusb: Some Qualcomm Bluetooth adapters stop working
-
-This issue starts from linux-5.10-rc1, I reproduced this issue on my
-Dell Inspiron 7447 with BT adapter 0cf3:e005, the kernel will print
-out: "Bluetooth: hci0: don't support firmware rome 0x31010000", and
-someone else also reported the similar issue to bugzilla #211571.
-
-I found this is a regression introduced by 'commit b40f58b97386
-("Bluetooth: btusb: Add Qualcomm Bluetooth SoC WCN6855 support"), the
-patch assumed that if high ROM version is not zero, it is an adapter
-on WCN6855, but many old adapters don't need to load rampatch or nvm,
-and they have non-zero high ROM version.
-
-To fix it, let the driver match the rom_version in the
-qca_devices_table first, if there is no entry matched, check the
-high ROM version, if it is not zero, we assume this adapter is ready
-to work and no need to load rampatch and nvm like previously.
-
-BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=211571
-Fixes: b40f58b97386 ("Bluetooth: btusb: Add Qualcomm Bluetooth SoC WCN6855 support")
-Signed-off-by: Hui Wang <hui.wang@canonical.com>
-Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
----
- drivers/bluetooth/btusb.c | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
-index 03b83aa91277..32161dd40ed6 100644
---- a/drivers/bluetooth/btusb.c
-+++ b/drivers/bluetooth/btusb.c
-@@ -4069,6 +4069,13 @@ static int btusb_setup_qca(struct hci_dev *hdev)
- info = &qca_devices_table[i];
- }
- if (!info) {
-+ /* If the rom_version is not matched in the qca_devices_table
-+ * and the high ROM version is not zero, we assume this chip no
-+ * need to load the rampatch and nvm.
-+ */
-+ if (ver_rom & ~0xffffU)
-+ return 0;
-+
- bt_dev_err(hdev, "don't support firmware rome 0x%x", ver_rom);
- return -ENODEV;
- }
---
-cgit v1.2.3-1-gf6bb5
-
diff --git a/0003-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch b/0002-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
index a9b880d..a9b880d 100644
--- a/0003-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
+++ b/0002-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
diff --git a/0004-drm-amdgpu-fix-shutdown-with-s0ix.patch b/0003-drm-amdgpu-fix-shutdown-with-s0ix.patch
index 0427bc0..0427bc0 100644
--- a/0004-drm-amdgpu-fix-shutdown-with-s0ix.patch
+++ b/0003-drm-amdgpu-fix-shutdown-with-s0ix.patch
diff --git a/PKGBUILD b/PKGBUILD
index 94f8c18..96dd78b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=11
-_minver=0
+_minver=2
_gccpatchver='20201113'
_gccpatchger='10.1'
_gccpatchker='5.8'
@@ -33,7 +33,7 @@ _ckpatchversion=ck1
else
pkgver=${_supver}.${_majver}.${_minver}
fi
-pkgrel=2
+pkgrel=0
pkgdesc='Linux-ck'
url='https://kernel.org'
#url='http://ck.kolivas.org/patches/'
@@ -51,9 +51,8 @@ source=(
config # the main kernel config file
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch
- 0003-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
- 0004-drm-amdgpu-fix-shutdown-with-s0ix.patch
+ 0002-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
+ 0003-drm-amdgpu-fix-shutdown-with-s0ix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
raid6-default-algo.patch
@@ -63,12 +62,11 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('81300c27bd5476387a83123aaeb4163c73eb61e9245806c23660cb5e6a4fa88ffc9def027031335fa0270fc4080506cd415990014364e3a98b9d2e8c58a29524'
+b2sums=('62f47c769998fa713cda9024a4ecbe7ba2140acde629082630c2c0b076b4e941b0a1e82f7d2b7cd4ed6e84759ea93de78e212ecbe1341d9055091d26d83286dc'
'SKIP'
'926ec7985fea53a4b95485dd43acc7bb6ac3d5084e47a7866c4c83f8dcab22e73dd7d1ea8a08d13cffa56dc196768e0de3b9153090ffe801d9b6afd13b8ed6ab'
'81d948aef4423255ebb4fa9b12c96207af8d14e225cf95d631dfbb1c0e88d31f60f81c2aff63046a78d8daf2601270ebb1d9cfaeccc3e3fdb08dbc430b53aff5'
'2f9195675270d79d735a3aaec25887c2f80b76eae98be8fcc5fd59ab71d925c5ee20ec5e2a015deb68b61bc2cc7f56f546a22cb96ee038e2e24c2c9dd5c3f79f'
- 'ee2176084665f1a5f1999157cb128c8c68c113b5d22c4d72bec689123493d7a9b246e1c7cff7d6ff4bba8d5c5624b4dc75f2274db941e9b3d352e41fbad86927'
'1e3a9aadc3e944afd9601457f69218fd4cf61badabed6924622bce3273c2a95602fc6aab00c1399767f5115d3fbecde391b553acc259c817f8d6b29a18b1f8ad'
'a5c4d1bf3b15e3ee2491f75485627ebf1a9f6759f38798c08fcd09bf90b40fed997d7f14190809f4e676907f8a1c9150e3de2da856c8b92e022d3250a86040fe'
'7f1eb5938472f57748216bd00e0c875feab99fc1c5cb89babfea467ee30ca5c8e9fc5a691efe2e602bef1ea79820c5383822d7cec354b48d23321ccda8ee8127'
@@ -92,9 +90,8 @@ prepare() {
# Hotfixes
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- patch -p1 -i ../0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch
- patch -p1 -i ../0003-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
- patch -p1 -i ../0004-drm-amdgpu-fix-shutdown-with-s0ix.patch
+ patch -p1 -i ../0002-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
+ patch -p1 -i ../0003-drm-amdgpu-fix-shutdown-with-s0ix.patch
# ck patch
@@ -138,10 +135,10 @@ prepare() {
make olddefconfig
-# if [ -f $HOME/.config/modprobed.db ]; then
-# echo "Running make localmodconfig"
-# make LSMOD=$HOME/.config/modprobed.db localmodconfig
-# fi
+ if [ -f $HOME/.config/modprobed.db ]; then
+ echo "Running make localmodconfig"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ fi
if [ "$_custom" == "1" ]; then
make menuconfig