summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-04-17 22:14:30 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-04-17 22:14:30 -0700
commitc303dc55d7bcf3e4d37f7d4cb52caf62d8901d2c (patch)
treeabdfeb91143521d12bf00b8938382318be63c518
parentMinor PKGBUILD reordering (diff)
downloadlinux-ck-c303dc55d7bcf3e4d37f7d4cb52caf62d8901d2c.tar.xz
Updated to 5.0.8
Added bdver2 patch for graysky gcc patch
-rw-r--r--PKGBUILD14
-rw-r--r--bdver2-fix-for-graysky.patch11
2 files changed, 21 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ff06f4..d9b17e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Maintainer (Arch): Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer (Arch): Thomas Baechler <thomas@archlinux.org>
+# Contributor (Arch): Thomas Baechler <thomas@archlinux.org>
# Contributor: Aqua-sama <aqua@iserlohn-fortress.net>
# # I maintain this because:
# Arch version patch script does not apply consistently
-# Arch version lacks ath9k, greysky2, and raid6 patches
+# Arch version lacks ath9k, bdver2, greysky2, and raid6 patches
# Arch version lacks ck patches
# Arch version allows SEED, SM3, SM4, and Streebog
# Arch version is 300 Hz
@@ -17,7 +17,7 @@
pkgbase=linux-ck
_majver=5.0
-_minver=7
+_minver=8
pkgver=${_majver}.${_minver}
_ckpatchversion=1
_ckpatch="patch-5.0-ck${_ckpatchversion}"
@@ -35,6 +35,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sig
remove-excess-ck-extraversion.patch
http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
+ bdver2-fix-for-graysky.patch
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
ath9k-regdom-hack.patch
raid6-default-algo.patch
@@ -43,11 +44,12 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sig
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('16e177662b9fc7255bfc51018513979f6effcbe52e459c543aa83a5b15ef54ec'
+sha256sums=('11908044e8cce1e093141f8da594708d45d05d0381676ae9aa3d8aeaf7c85435'
'SKIP'
'2a551169f8cbb424900372fe698ae9003fbcad3614a46ca3f56b103f9c1ea763'
'661f64bbd8bf49afcc7c760c4148b2e2108511a1eadcae917cfe6056a83d8476'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
+ 'd35338c92d0dbf27ffedaf100bd852dd13fd9b5d49b12a10b91194a2ae654447'
'91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
'0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
@@ -85,6 +87,10 @@ prepare() {
msg2 "Applying graysky2 cpu patch"
patch -p1 -i ../kernel_gcc_patch-${_gcc_more_v}/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
+ # Fix stack warnings and ldconfig segfaults on bdver2 with graysky2 gcc patch
+ msg2 "Applying bdver2 fix for graysky2 cpu patch"
+ patch -p1 -i ../bdver2-fix-for-graysky.patch
+
# 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
msg2 "Applying disallow-unpriv-clone-newuser patch"
patch -p1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
diff --git a/bdver2-fix-for-graysky.patch b/bdver2-fix-for-graysky.patch
new file mode 100644
index 0000000..b7e5402
--- /dev/null
+++ b/bdver2-fix-for-graysky.patch
@@ -0,0 +1,11 @@
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -492,7 +492,7 @@
+ cflags-$(CONFIG_MBOBCAT) += $(call cc-option,-march=btver1)
+ cflags-$(CONFIG_MJAGUAR) += $(call cc-option,-march=btver2)
+ cflags-$(CONFIG_MBULLDOZER) += $(call cc-option,-march=bdver1)
+- cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2)
++ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2) $(call cc-option,-mno-tbm)
+ cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-march=bdver3)
+ cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-march=bdver4)
+ cflags-$(CONFIG_MZEN) += $(call cc-option,-march=znver1)