summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-02-05 17:09:15 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-02-05 17:09:15 +0200
commitfa376638f8d3626c14594a2132a1e767264e74fd (patch)
treedb6b1bf01da8bc6d5caab8b4b8ced827267530a1
parentAdd more aliases for gcc patch versions (diff)
downloadlinux-ck-fa376638f8d3626c14594a2132a1e767264e74fd.tar.xz
Fix zfs-dkms breakage due to GPL zealotry
-rw-r--r--PKGBUILD4
-rw-r--r--zfs.patch20
2 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e8c5dc..c9b146a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,6 +51,7 @@ source=(
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
raid6-default-algo.patch
+ zfs.patch
config # the main kernel config file
)
validpgpkeys=(
@@ -69,6 +70,7 @@ b2sums=('9587b8d8307c134a7732482e5495d9203a6367483ca30be06c13b270f4ce34b532d9358
'd76bd0bf237ea2bb7999fd3715cb664d89148cb0ade8057d57cdb40bc0a7954336e50ee077312e5e192398b0f35f055786deb98af9130d57e60f2ea040fbb66f'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
+ '4b982e16e3fee2c2c40db08d67a6cc794c27308c4b513a9baf909c5ea40e3be239288ba4c422e8eb58a669646d331e7fd945d7451d1a388f1c68fe3a445aa814'
'19636a1b390220cb60de35456bef0938f7d061d64ac89a1abf9eb3c1f3812a3768d80cb2a044a69ae4b67297a41c24bd68eaef57cf696bc1435dc22d39c7377e')
#export KBUILD_BUILD_HOST=arc4linux
@@ -92,6 +94,8 @@ prepare() {
patch -p1 -i ../0003-ALSA-hda-Fix-DP-MST-support-for-NVIDIA-codecs.patch
patch -p1 -i ../0004-btrfs-send-fix-emission-of-invalid-clone-operations-within-the-same.patch
+ msg2 "Fixing ZFS compatibility"
+ patch -p1 -i ../zfs.patch
# fix naming schema in EXTRAVERSION of ck patch set
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}"
diff --git a/zfs.patch b/zfs.patch
new file mode 100644
index 0000000..7df5914
--- /dev/null
+++ b/zfs.patch
@@ -0,0 +1,20 @@
+--- a/kernel/rcu/tree_plugin.h
++++ b/kernel/rcu/tree_plugin.h
+@@ -360,7 +360,7 @@
+ WARN_ON_ONCE(current->rcu_read_lock_nesting > RCU_NEST_PMAX);
+ barrier(); /* critical section after entry code. */
+ }
+-EXPORT_SYMBOL_GPL(__rcu_read_lock);
++EXPORT_SYMBOL(__rcu_read_lock);
+
+ /*
+ * Preemptible RCU implementation for rcu_read_unlock().
+@@ -390,7 +390,7 @@
+ WARN_ON_ONCE(rrln < 0 && rrln > RCU_NEST_NMAX);
+ }
+ }
+-EXPORT_SYMBOL_GPL(__rcu_read_unlock);
++EXPORT_SYMBOL(__rcu_read_unlock);
+
+ /*
+ * Advance a ->blkd_tasks-list pointer to the next entry, instead