summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-05-28 10:30:56 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-05-28 11:01:41 +0300
commit2a2abadf0c26863318fb5c84d7f0385fbc254ce9 (patch)
tree738d0edc3f3216757cb90014618fd951f673da68
parentUpdated to 5.6.14 (diff)
downloadlinux-ck-2a2abadf0c26863318fb5c84d7f0385fbc254ce9.tar.xz
Update to 5.6.15
-rw-r--r--0002-gcc-plugins-drop-support-for-GCC-47.patch277
-rw-r--r--0003-gcc-common.h-Update-for-GCC-10.patch86
-rw-r--r--PKGBUILD11
3 files changed, 3 insertions, 371 deletions
diff --git a/0002-gcc-plugins-drop-support-for-GCC-47.patch b/0002-gcc-plugins-drop-support-for-GCC-47.patch
deleted file mode 100644
index 81698a8..0000000
--- a/0002-gcc-plugins-drop-support-for-GCC-47.patch
+++ /dev/null
@@ -1,277 +0,0 @@
-From dba68a9d4df76d49d32245e4236713a43fb321da Mon Sep 17 00:00:00 2001
-From: Masahiro Yamada <masahiroy@kernel.org>
-Date: Sun, 29 Mar 2020 20:08:32 +0900
-Subject: gcc-plugins: drop support for GCC <= 4.7
-
-Nobody was opposed to raising minimum GCC version to 4.8 [1]
-So, we will drop GCC <= 4.7 support sooner or later.
-
-We always use C++ compiler for building plugins for GCC >= 4.8.
-
-This commit drops the plugin support for GCC <= 4.7 a bit earlier,
-which allows us to dump lots of code.
-
-[1] https://lkml.org/lkml/2020/1/23/545
-
-Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
-Acked-by: Kees Cook <keescook@chromium.org>
----
- scripts/Kconfig.include | 3 ---
- scripts/Makefile.build | 2 +-
- scripts/Makefile.clean | 1 -
- scripts/Makefile.host | 23 +-----------------
- scripts/gcc-plugin.sh | 55 ++++----------------------------------------
- scripts/gcc-plugins/Kconfig | 12 ++--------
- scripts/gcc-plugins/Makefile | 21 +++++------------
- 7 files changed, 14 insertions(+), 103 deletions(-)
-
-diff --git a/scripts/Kconfig.include b/scripts/Kconfig.include
-index 496d11c92c97..033f6efd92d3 100644
---- a/scripts/Kconfig.include
-+++ b/scripts/Kconfig.include
-@@ -42,9 +42,6 @@ $(error-if,$(failure,command -v $(LD)),linker '$(LD)' not found)
- # Fail if the linker is gold as it's not capable of linking the kernel proper
- $(error-if,$(success, $(LD) -v | grep -q gold), gold linker '$(LD)' not supported)
-
--# gcc version including patch level
--gcc-version := $(shell,$(srctree)/scripts/gcc-version.sh $(CC))
--
- # machine bit flags
- # $(m32-flag): -m32 if the compiler supports it, or an empty string otherwise.
- # $(m64-flag): -m64 if the compiler supports it, or an empty string otherwise.
-diff --git a/scripts/Makefile.build b/scripts/Makefile.build
-index a1730d42e5f3..eec789d7a63a 100644
---- a/scripts/Makefile.build
-+++ b/scripts/Makefile.build
-@@ -46,7 +46,7 @@ include $(kbuild-file)
- include scripts/Makefile.lib
-
- # Do not include host rules unless needed
--ifneq ($(hostprogs)$(hostlibs-y)$(hostlibs-m)$(hostcxxlibs-y)$(hostcxxlibs-m),)
-+ifneq ($(hostprogs)$(hostcxxlibs-y)$(hostcxxlibs-m),)
- include scripts/Makefile.host
- endif
-
-diff --git a/scripts/Makefile.clean b/scripts/Makefile.clean
-index 1e4206566a82..075f0cc2d8d7 100644
---- a/scripts/Makefile.clean
-+++ b/scripts/Makefile.clean
-@@ -30,7 +30,6 @@ subdir-ymn := $(addprefix $(obj)/,$(subdir-ymn))
- __clean-files := $(extra-y) $(extra-m) $(extra-) \
- $(always) $(always-y) $(always-m) $(always-) $(targets) $(clean-files) \
- $(hostprogs) $(hostprogs-y) $(hostprogs-m) $(hostprogs-) \
-- $(hostlibs-y) $(hostlibs-m) $(hostlibs-) \
- $(hostcxxlibs-y) $(hostcxxlibs-m)
-
- __clean-files := $(filter-out $(no-clean-files), $(__clean-files))
-diff --git a/scripts/Makefile.host b/scripts/Makefile.host
-index 3b7121d43324..2045855d0b75 100644
---- a/scripts/Makefile.host
-+++ b/scripts/Makefile.host
-@@ -39,7 +39,6 @@ $(obj)/%.tab.c $(obj)/%.tab.h: $(src)/%.y FORCE
- # They are linked as C++ code to the executable qconf
-
- __hostprogs := $(sort $(hostprogs))
--host-cshlib := $(sort $(hostlibs-y) $(hostlibs-m))
- host-cxxshlib := $(sort $(hostcxxlibs-y) $(hostcxxlibs-m))
-
- # C code
-@@ -63,7 +62,6 @@ host-cxxmulti := $(foreach m,$(__hostprogs),$(if $($(m)-cxxobjs),$(m)))
- host-cxxobjs := $(sort $(foreach m,$(host-cxxmulti),$($(m)-cxxobjs)))
-
- # Object (.o) files used by the shared libaries
--host-cshobjs := $(sort $(foreach m,$(host-cshlib),$($(m:.so=-objs))))
- host-cxxshobjs := $(sort $(foreach m,$(host-cxxshlib),$($(m:.so=-objs))))
-
- host-csingle := $(addprefix $(obj)/,$(host-csingle))
-@@ -71,9 +69,7 @@ host-cmulti := $(addprefix $(obj)/,$(host-cmulti))
- host-cobjs := $(addprefix $(obj)/,$(host-cobjs))
- host-cxxmulti := $(addprefix $(obj)/,$(host-cxxmulti))
- host-cxxobjs := $(addprefix $(obj)/,$(host-cxxobjs))
--host-cshlib := $(addprefix $(obj)/,$(host-cshlib))
- host-cxxshlib := $(addprefix $(obj)/,$(host-cxxshlib))
--host-cshobjs := $(addprefix $(obj)/,$(host-cshobjs))
- host-cxxshobjs := $(addprefix $(obj)/,$(host-cxxshobjs))
-
- #####
-@@ -140,13 +136,6 @@ quiet_cmd_host-cxxobjs = HOSTCXX $@
- $(host-cxxobjs): $(obj)/%.o: $(src)/%.cc FORCE
- $(call if_changed_dep,host-cxxobjs)
-
--# Compile .c file, create position independent .o file
--# host-cshobjs -> .o
--quiet_cmd_host-cshobjs = HOSTCC -fPIC $@
-- cmd_host-cshobjs = $(HOSTCC) $(hostc_flags) -fPIC -c -o $@ $<
--$(host-cshobjs): $(obj)/%.o: $(src)/%.c FORCE
-- $(call if_changed_dep,host-cshobjs)
--
- # Compile .c file, create position independent .o file
- # Note that plugin capable gcc versions can be either C or C++ based
- # therefore plugin source files have to be compilable in both C and C++ mode.
-@@ -157,16 +146,6 @@ quiet_cmd_host-cxxshobjs = HOSTCXX -fPIC $@
- $(host-cxxshobjs): $(obj)/%.o: $(src)/%.c FORCE
- $(call if_changed_dep,host-cxxshobjs)
-
--# Link a shared library, based on position independent .o files
--# *.o -> .so shared library (host-cshlib)
--quiet_cmd_host-cshlib = HOSTLLD -shared $@
-- cmd_host-cshlib = $(HOSTCC) $(KBUILD_HOSTLDFLAGS) -shared -o $@ \
-- $(addprefix $(obj)/, $($(target-stem)-objs)) \
-- $(KBUILD_HOSTLDLIBS) $(HOSTLDLIBS_$(target-stem).so)
--$(host-cshlib): FORCE
-- $(call if_changed,host-cshlib)
--$(call multi_depend, $(host-cshlib), .so, -objs)
--
- # Link a shared library, based on position independent .o files
- # *.o -> .so shared library (host-cxxshlib)
- quiet_cmd_host-cxxshlib = HOSTLLD -shared $@
-@@ -178,4 +157,4 @@ $(host-cxxshlib): FORCE
- $(call multi_depend, $(host-cxxshlib), .so, -objs)
-
- targets += $(host-csingle) $(host-cmulti) $(host-cobjs)\
-- $(host-cxxmulti) $(host-cxxobjs) $(host-cshlib) $(host-cshobjs) $(host-cxxshlib) $(host-cxxshobjs)
-+ $(host-cxxmulti) $(host-cxxobjs) $(host-cxxshlib) $(host-cxxshobjs)
-diff --git a/scripts/gcc-plugin.sh b/scripts/gcc-plugin.sh
-index d3caefe53eab..b79fd0bea838 100755
---- a/scripts/gcc-plugin.sh
-+++ b/scripts/gcc-plugin.sh
-@@ -1,49 +1,14 @@
- #!/bin/sh
- # SPDX-License-Identifier: GPL-2.0
--srctree=$(dirname "$0")
--
--SHOW_ERROR=
--if [ "$1" = "--show-error" ] ; then
-- SHOW_ERROR=1
-- shift || true
--fi
--
--gccplugins_dir=$($3 -print-file-name=plugin)
--plugincc=$($1 -E -x c++ - -o /dev/null -I"${srctree}"/gcc-plugins -I"${gccplugins_dir}"/include 2>&1 <<EOF
--#include "gcc-common.h"
--#if BUILDING_GCC_VERSION >= 4008 || defined(ENABLE_BUILD_WITH_CXX)
--#warning $2 CXX
--#else
--#warning $1 CC
--#endif
--EOF
--)
-
--if [ $? -ne 0 ]
--then
-- if [ -n "$SHOW_ERROR" ] ; then
-- echo "${plugincc}" >&2
-- fi
-- exit 1
--fi
-+set -e
-
--case "$plugincc" in
-- *"$1 CC"*)
-- echo "$1"
-- exit 0
-- ;;
--
-- *"$2 CXX"*)
-- # the c++ compiler needs another test, see below
-- ;;
-+srctree=$(dirname "$0")
-
-- *)
-- exit 1
-- ;;
--esac
-+gccplugins_dir=$($* -print-file-name=plugin)
-
- # we need a c++ compiler that supports the designated initializer GNU extension
--plugincc=$($2 -c -x c++ -std=gnu++98 - -fsyntax-only -I"${srctree}"/gcc-plugins -I"${gccplugins_dir}"/include 2>&1 <<EOF
-+$HOSTCC -c -x c++ -std=gnu++98 - -fsyntax-only -I $srctree/gcc-plugins -I $gccplugins_dir/include 2>/dev/null <<EOF
- #include "gcc-common.h"
- class test {
- public:
-@@ -52,15 +17,3 @@ public:
- .test = 1
- };
- EOF
--)
--
--if [ $? -eq 0 ]
--then
-- echo "$2"
-- exit 0
--fi
--
--if [ -n "$SHOW_ERROR" ] ; then
-- echo "${plugincc}" >&2
--fi
--exit 1
-diff --git a/scripts/gcc-plugins/Kconfig b/scripts/gcc-plugins/Kconfig
-index e3569543bdac..fd31ed5b435f 100644
---- a/scripts/gcc-plugins/Kconfig
-+++ b/scripts/gcc-plugins/Kconfig
-@@ -1,13 +1,4 @@
- # SPDX-License-Identifier: GPL-2.0-only
--preferred-plugin-hostcc := $(if-success,[ $(gcc-version) -ge 40800 ],$(HOSTCXX),$(HOSTCC))
--
--config PLUGIN_HOSTCC
-- string
-- default "$(shell,$(srctree)/scripts/gcc-plugin.sh "$(preferred-plugin-hostcc)" "$(HOSTCXX)" "$(CC)")" if CC_IS_GCC
-- help
-- Host compiler used to build GCC plugins. This can be $(HOSTCXX),
-- $(HOSTCC), or a null string if GCC plugin is unsupported.
--
- config HAVE_GCC_PLUGINS
- bool
- help
-@@ -17,7 +8,8 @@ config HAVE_GCC_PLUGINS
- menuconfig GCC_PLUGINS
- bool "GCC plugins"
- depends on HAVE_GCC_PLUGINS
-- depends on PLUGIN_HOSTCC != ""
-+ depends on CC_IS_GCC && GCC_VERSION >= 40800
-+ depends on $(success,$(srctree)/scripts/gcc-plugin.sh $(CC))
- default y
- help
- GCC plugins are loadable modules that provide extra features to the
-diff --git a/scripts/gcc-plugins/Makefile b/scripts/gcc-plugins/Makefile
-index f2ee8bd7abc6..f22858b2c3d6 100644
---- a/scripts/gcc-plugins/Makefile
-+++ b/scripts/gcc-plugins/Makefile
-@@ -1,18 +1,9 @@
- # SPDX-License-Identifier: GPL-2.0
--PLUGINCC := $(CONFIG_PLUGIN_HOSTCC:"%"=%)
- GCC_PLUGINS_DIR := $(shell $(CC) -print-file-name=plugin)
-
--ifeq ($(PLUGINCC),$(HOSTCC))
-- HOSTLIBS := hostlibs
-- HOST_EXTRACFLAGS += -I$(GCC_PLUGINS_DIR)/include -I$(src) -std=gnu99 -ggdb
-- export HOST_EXTRACFLAGS
--else
-- HOSTLIBS := hostcxxlibs
-- HOST_EXTRACXXFLAGS += -I$(GCC_PLUGINS_DIR)/include -I$(src) -std=gnu++98 -fno-rtti
-- HOST_EXTRACXXFLAGS += -fno-exceptions -fasynchronous-unwind-tables -ggdb
-- HOST_EXTRACXXFLAGS += -Wno-narrowing -Wno-unused-variable
-- export HOST_EXTRACXXFLAGS
--endif
-+HOST_EXTRACXXFLAGS += -I$(GCC_PLUGINS_DIR)/include -I$(src) -std=gnu++98 -fno-rtti
-+HOST_EXTRACXXFLAGS += -fno-exceptions -fasynchronous-unwind-tables -ggdb
-+HOST_EXTRACXXFLAGS += -Wno-narrowing -Wno-unused-variable -Wno-c++11-compat
-
- $(obj)/randomize_layout_plugin.o: $(objtree)/$(obj)/randomize_layout_seed.h
- quiet_cmd_create_randomize_layout_seed = GENSEED $@
-@@ -22,9 +13,9 @@ $(objtree)/$(obj)/randomize_layout_seed.h: FORCE
- $(call if_changed,create_randomize_layout_seed)
- targets = randomize_layout_seed.h randomize_layout_hash.h
-
--$(HOSTLIBS)-y := $(foreach p,$(GCC_PLUGIN),$(if $(findstring /,$(p)),,$(p)))
--always-y := $($(HOSTLIBS)-y)
-+hostcxxlibs-y := $(foreach p,$(GCC_PLUGIN),$(if $(findstring /,$(p)),,$(p)))
-+always-y := $(hostcxxlibs-y)
-
--$(foreach p,$($(HOSTLIBS)-y:%.so=%),$(eval $(p)-objs := $(p).o))
-+$(foreach p,$(hostcxxlibs-y:%.so=%),$(eval $(p)-objs := $(p).o))
-
- clean-files += *.so
---
-cgit v1.2.3-1-gf6bb5
-
diff --git a/0003-gcc-common.h-Update-for-GCC-10.patch b/0003-gcc-common.h-Update-for-GCC-10.patch
deleted file mode 100644
index ec4fc15..0000000
--- a/0003-gcc-common.h-Update-for-GCC-10.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From 41e53fdbbf5121960fd44427c2ae7536d8fdd701 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Fr=C3=A9d=C3=A9ric=20Pierret=20=28fepitre=29?=
- <frederic.pierret@qubes-os.org>
-Date: Tue, 7 Apr 2020 13:32:59 +0200
-Subject: gcc-common.h: Update for GCC 10
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Remove "params.h" include, which has been dropped in GCC 10.
-
-Remove is_a_helper() macro, which is now defined in gimple.h, as seen
-when running './scripts/gcc-plugin.sh g++ g++ gcc':
-
-In file included from <stdin>:1:
-./gcc-plugins/gcc-common.h:852:13: error: redefinition of ‘static bool is_a_helper<T>::test(U*) [with U = const gimple; T = const ggoto*]’
- 852 | inline bool is_a_helper<const ggoto *>::test(const_gimple gs)
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~
-In file included from ./gcc-plugins/gcc-common.h:125,
- from <stdin>:1:
-/usr/lib/gcc/x86_64-redhat-linux/10/plugin/include/gimple.h:1037:1: note: ‘static bool is_a_helper<T>::test(U*) [with U = const gimple; T = const ggoto*]’ previously declared here
- 1037 | is_a_helper <const ggoto *>::test (const gimple *gs)
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-Add -Wno-format-diag to scripts/gcc-plugins/Makefile to avoid
-meaningless warnings from error() formats used by plugins:
-
-scripts/gcc-plugins/structleak_plugin.c: In function ‘int plugin_init(plugin_name_args*, plugin_gcc_version*)’:
-scripts/gcc-plugins/structleak_plugin.c:253:12: warning: unquoted sequence of 2 consecutive punctuation characters ‘'-’ in format [-Wformat-diag]
- 253 | error(G_("unknown option '-fplugin-arg-%s-%s'"), plugin_name, argv[i].key);
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-Signed-off-by: Frédéric Pierret (fepitre) <frederic.pierret@qubes-os.org>
-Link: https://lore.kernel.org/r/20200407113259.270172-1-frederic.pierret@qubes-os.org
-[kees: include -Wno-format-diag for plugin builds]
-Signed-off-by: Kees Cook <keescook@chromium.org>
----
- scripts/gcc-plugins/Makefile | 1 +
- scripts/gcc-plugins/gcc-common.h | 4 ++++
- 2 files changed, 5 insertions(+)
-
-diff --git a/scripts/gcc-plugins/Makefile b/scripts/gcc-plugins/Makefile
-index f22858b2c3d6..80f354289eeb 100644
---- a/scripts/gcc-plugins/Makefile
-+++ b/scripts/gcc-plugins/Makefile
-@@ -4,6 +4,7 @@ GCC_PLUGINS_DIR := $(shell $(CC) -print-file-name=plugin)
- HOST_EXTRACXXFLAGS += -I$(GCC_PLUGINS_DIR)/include -I$(src) -std=gnu++98 -fno-rtti
- HOST_EXTRACXXFLAGS += -fno-exceptions -fasynchronous-unwind-tables -ggdb
- HOST_EXTRACXXFLAGS += -Wno-narrowing -Wno-unused-variable -Wno-c++11-compat
-+HOST_EXTRACXXFLAGS += -Wno-format-diag
-
- $(obj)/randomize_layout_plugin.o: $(objtree)/$(obj)/randomize_layout_seed.h
- quiet_cmd_create_randomize_layout_seed = GENSEED $@
-diff --git a/scripts/gcc-plugins/gcc-common.h b/scripts/gcc-plugins/gcc-common.h
-index 17f06079a712..9ad76b7f3f10 100644
---- a/scripts/gcc-plugins/gcc-common.h
-+++ b/scripts/gcc-plugins/gcc-common.h
-@@ -35,7 +35,9 @@
- #include "ggc.h"
- #include "timevar.h"
-
-+#if BUILDING_GCC_VERSION < 10000
- #include "params.h"
-+#endif
-
- #if BUILDING_GCC_VERSION <= 4009
- #include "pointer-set.h"
-@@ -847,6 +849,7 @@ static inline gimple gimple_build_assign_with_ops(enum tree_code subcode, tree l
- return gimple_build_assign(lhs, subcode, op1, op2 PASS_MEM_STAT);
- }
-
-+#if BUILDING_GCC_VERSION < 10000
- template <>
- template <>
- inline bool is_a_helper<const ggoto *>::test(const_gimple gs)
-@@ -860,6 +863,7 @@ inline bool is_a_helper<const greturn *>::test(const_gimple gs)
- {
- return gs->code == GIMPLE_RETURN;
- }
-+#endif
-
- static inline gasm *as_a_gasm(gimple stmt)
- {
---
-cgit v1.2.3-1-gf6bb5
-
diff --git a/PKGBUILD b/PKGBUILD
index 7f6e64c..00e5e8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@
pkgbase=linux-ck
_supver=5
_majver=6
-_minver=14
+_minver=15
_gccpatchver='20191217'
_gccpatchger='9.1'
_gccpatchker='5.5'
@@ -44,8 +44,6 @@ _srcname=linux-${pkgver}
source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-gcc-plugins-drop-support-for-GCC-47.patch
- 0003-gcc-common.h-Update-for-GCC-10.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
graysky_bdver2-hotfix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
@@ -59,11 +57,9 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('6613ae43fde5313c972a314a5e4008d32da51b87a5773e2f9819d53209e8661fd7436e029a3b28f21e26aab937fb0a4b1b6891bd1f865b642a386ae3d89470f7'
+b2sums=('3e38479d0921015d37473b110b6f7a4a94ce12f3fc6b64030c13a12c59b7683cda9a16ae031f4fbd7d0032cbaa3075aa31a1243717ccaeae0022b6fcb2eb3c5a'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
- 'bb02c251158116f98241f7de95339fb3ffee4748171c89bb5ef666ec28676c4a36fe6ff5d93d315b451aac4cb56343c435cdd46d3249d09e2a8cba47bba594eb'
- 'e59aa4ed958bad23f84d1cfb567d97090ca1a4f442c52297786035db89823eac3fc603035304d9466db87b62664b3c444c2749019eb963e0cbc8752d78fc684f'
'20dba509c16cf41226414c2e70e2a3434573638bf93ce25786c2cd4663c98bfa04845cda780c750afbfa26918cffa394d905d16bd687d6145acb8dbd2489fdd0'
'1892bd22775eac3bcc4d37f4fd30c95346bf3a0888cbbff57fd614973b525390dff2e315ce35b2e498523cceaab94ff21a80475dee8df3de4dd8fc0fab07d74e'
'd76bd0bf237ea2bb7999fd3715cb664d89148cb0ade8057d57cdb40bc0a7954336e50ee077312e5e192398b0f35f055786deb98af9130d57e60f2ea040fbb66f'
@@ -87,8 +83,7 @@ prepare() {
# Hotfixes
- msg2 "Applying hotfixes"
- for p in ../00*.patch; do echo "applying $p"; patch -p1 -i $p; done
+ for p in ../00*.patch; do msg2 "applying $p"; patch -p1 -i $p; done
patch -p1 -i ../sphinx-workaround.patch
# fix naming schema in EXTRAVERSION of ck patch set