summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-10-07 01:17:48 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-10-07 01:17:48 -0700
commit39c73e83ed949d422c07b2cdd6a9e49f78d63675 (patch)
tree95ff19eca748e58095002dbba50eb47a1d743f3c
parentUpdated to 5.2.17 (diff)
downloadlinux-ck-39c73e83ed949d422c07b2cdd6a9e49f78d63675.tar.xz
Updated to 5.2.19
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 446e858..43cbcad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@
pkgbase=linux-ck
_majver=5.2
-_minver=17
+_minver=19
if [ "$_minver" == "0" ]; then
pkgver=${_majver}
else
@@ -51,7 +51,7 @@ source=(
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('7b3b8ad09ea936b4216dd02c5fc2ef39c8f58935d0a81ab9690f0fc451102df9'
+sha256sums=('de98e4c28e08cd992c3aadc32450b3fa738b6101c509093192bb344f4f41b18a'
'SKIP'
'e862ecd2cb0b20e1859ec3e47616457a9a3acb111cd5a86094f9ed1dbd7f42ac'
'f1abc13a8d859fbf6350040e45d7f04ad551a6d39f113ba96fbbd820118c0e36'
@@ -88,6 +88,9 @@ prepare() {
# fix naming schema in EXTRAVERSION of ck patch set
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../linux-ck-patch-${_majver}-${_ckpatchversion}"
+ # fix ck1 patchset for 5.2.18
+ sed -i -e '/^-CFLAGS/ s,+=,:=,' -i -e '/^+CFLAGS/ s,+=,:=,' ../"${_ckpatch}"
+
# ck patch
msg2 "Applying ck patch"
patch -F 3 -Np1 -i ../linux-ck-patch-${_majver}-${_ckpatchversion}
@@ -167,8 +170,9 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
[[ $pkgbase = linux ]] && groups=(base)
- depends=(coreutils linux-firmware kmod mkinitcpio)
- optdepends=('crda: to set the correct wireless channels of your country')
+ depends=(coreutils kmod mkinitcpio)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -180,6 +184,9 @@ _package() {
msg2 "Installing boot image..."
install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install