summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-05-25 15:57:09 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-05-25 15:57:09 -0700
commit4d7e2b7d40e788bf0109c336acc4371fd5fd0593 (patch)
tree3b77808c0ebeb8cfe1a1a8e15390c46a2ea13b0f
parentClean up hotfixes section (diff)
downloadlinux-ck-4d7e2b7d40e788bf0109c336acc4371fd5fd0593.tar.xz
Reorganized patches
-rw-r--r--PKGBUILD28
-rw-r--r--bdver2-fix-for-graysky.patch11
-rw-r--r--ck_remove-excess-extraversion.patch (renamed from remove-excess-ck-extraversion.patch)0
-rw-r--r--graysky_bdver2-hotfix.patch11
4 files changed, 27 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cea5991..06b4fc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,8 @@
# # I maintain this because:
# Arch version patch script does not apply consistently
-# Arch version lacks ath9k, bdver2, greysky2, and raid6 patches
+# Arch version lacks graysky gcc patch with bdver2 fix
+# Arch version lacks ath9k regdom and raid6 algo patches
# Arch version lacks ck patches
# Arch version allows SEED, SM3, SM4, and Streebog
# Arch version is 300 Hz
@@ -37,11 +38,11 @@ conflicts=('linux-libre')
options=('!strip')
source=(
https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar.{xz,sign}
- remove-excess-ck-extraversion.patch
+ 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ ck_remove-excess-extraversion.patch
http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
+ graysky_bdver2-hotfix.patch
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
- bdver2-fix-for-graysky.patch
- 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
ath9k-regdom-hack.patch
raid6-default-algo.patch
config.x86_64 # the main kernel config files
@@ -51,11 +52,11 @@ source=(
)
sha256sums=('d79f90f5ca97befbfee4e247204b2ac4f45e7bb03d63a79184bc748cf3cf6ddb'
'SKIP'
+ '91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
'a2db6672b2d35f3006c7151e8fa90f5187dcdac9fcc46e88e78d45c7d8226d1f'
'f8d18a34f6b17ec8e5f2a7354383ca627e0fd00b5578c1ee7d9808a34f33c724'
+ '229e063a578db0a278108f37b24da20c2a2a18d825e98a67e426cb0f4b492e4a'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
- 'd35338c92d0dbf27ffedaf100bd852dd13fd9b5d49b12a10b91194a2ae654447'
- '91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
'0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
'b1a69a9bccdeab017fd1ee3cb86495e3f499bf82cb94c1ca062e2fc086584311'
@@ -82,21 +83,24 @@ prepare() {
msg2 "Applying hotfixes"
patch -p1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+
# ck hotfixes
msg2 "Applying ck patch hotfixes"
- patch -p1 -i ../remove-excess-ck-extraversion.patch "$srcdir/${_ckpatch}"
+ patch -p1 -i ../ck_remove-excess-extraversion.patch "$srcdir/${_ckpatch}"
# ck patch
msg2 "Applying ck patch"
patch -F 3 -Np1 -i ../${_ckpatch}
- # graysky2 gcc patch
- msg2 "Applying graysky2 cpu patch"
+
+ # graysky gcc hotfixes
+ msg2 "Applying graysky gcc patch hotfixes"
+ patch -p1 -i ../graysky_bdver2-hotfix.patch "$srcdir/kernel_gcc_patch-${_gcc_more_v}/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch"
+
+ # graysky gcc patch
+ msg2 "Applying graysky cpu patch"
patch -p1 -i ../kernel_gcc_patch-${_gcc_more_v}/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
- # Fix stack warnings and ldconfig segfaults on bdver2 with graysky2 gcc patch
- msg2 "Applying bdver2 fix for graysky2 cpu patch"
- patch -p1 -i ../bdver2-fix-for-graysky.patch
# Ignore ath9k eeprom patch
msg2 "Applying ath9k patch"
diff --git a/bdver2-fix-for-graysky.patch b/bdver2-fix-for-graysky.patch
deleted file mode 100644
index b7e5402..0000000
--- a/bdver2-fix-for-graysky.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/x86/Makefile
-+++ b/arch/x86/Makefile
-@@ -492,7 +492,7 @@
- cflags-$(CONFIG_MBOBCAT) += $(call cc-option,-march=btver1)
- cflags-$(CONFIG_MJAGUAR) += $(call cc-option,-march=btver2)
- cflags-$(CONFIG_MBULLDOZER) += $(call cc-option,-march=bdver1)
-- cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2)
-+ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2) $(call cc-option,-mno-tbm)
- cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-march=bdver3)
- cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-march=bdver4)
- cflags-$(CONFIG_MZEN) += $(call cc-option,-march=znver1)
diff --git a/remove-excess-ck-extraversion.patch b/ck_remove-excess-extraversion.patch
index 9182f31..9182f31 100644
--- a/remove-excess-ck-extraversion.patch
+++ b/ck_remove-excess-extraversion.patch
diff --git a/graysky_bdver2-hotfix.patch b/graysky_bdver2-hotfix.patch
new file mode 100644
index 0000000..5cd9dbc
--- /dev/null
+++ b/graysky_bdver2-hotfix.patch
@@ -0,0 +1,11 @@
+--- a/kernel_gcc_patch-20180509/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
++++ b/kernel_gcc_patch-20180509/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
+@@ -492,7 +492,7 @@ + cflags-$(CONFIG_MBARCELONA) += $(call cc-option,-march=barcelona)
+ + cflags-$(CONFIG_MBOBCAT) += $(call cc-option,-march=btver1)
+ + cflags-$(CONFIG_MJAGUAR) += $(call cc-option,-march=btver2)
+ + cflags-$(CONFIG_MBULLDOZER) += $(call cc-option,-march=bdver1)
+-+ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2)
+++ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2) $(call cc-option,-mno-tbm)
+ + cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-march=bdver3)
+ + cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-march=bdver4)
+ + cflags-$(CONFIG_MZEN) += $(call cc-option,-march=znver1)