summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-07-28 11:42:57 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-07-28 11:42:57 -0700
commit69561194bbc50eca84d71ee5b0b888001b73a43c (patch)
tree79ee65eb1ed47274160dba5ba29150e72c05d0df
parentUpdated to 5.2.3 (diff)
downloadlinux-ck-69561194bbc50eca84d71ee5b0b888001b73a43c.tar.xz
Updated to 5.2.4
Removed documentation package as per upstream AUR
-rw-r--r--PKGBUILD38
1 files changed, 3 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7001dc7..8c6083a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
pkgbase=linux-ck
_majver=5.2
-_minver=3
+_minver=4
if [ "$_minver" == "0" ]; then
pkgver=${_majver}
else
@@ -34,7 +34,6 @@ arch=('x86_64')
license=('GPL2')
makedepends=(
'xmlto' 'kmod' 'inetutils' 'bc' 'libelf'
- 'python-sphinx' 'python-sphinx_rtd_theme' 'graphviz' 'imagemagick'
)
conflicts=('linux-libre')
options=('!strip')
@@ -56,7 +55,7 @@ source=(
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('753c600939778804860498fa13002f5a6c4a3f086785015681f431bfd08f0e05'
+sha256sums=('b1cd8b9e0bfe7afb2fdf3915605db3a6cd3fe098833f9bc0b37aae74b057ee43'
'SKIP'
'91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
'63e4378e69e2f23ed87af32a4951477a6d82d4ac0de2295db46502c8120da9d9'
@@ -308,38 +307,7 @@ _package-headers() {
chmod -Rc u=rwX,go=rX "$pkgdir"
}
-_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
-
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
- cd $_srcname
-
- msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
-
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
- msg2 "Adding symlink..."
- mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-
- msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
-}
-
-pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
+pkgname=("$pkgbase" "$pkgbase-headers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")