summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-09-12 14:13:48 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-09-12 14:13:48 -0700
commit82e1a516fd8b1c96e3687b2ca23f51527ef09b6f (patch)
treecf6eb63c89f7f1625281658fd222e2b8d1e8597d
parentUpdated to 5.2.14 (diff)
downloadlinux-ck-82e1a516fd8b1c96e3687b2ca23f51527ef09b6f.tar.xz
Add hotfix for btrfs extent buffer hangs
-rw-r--r--0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch145
-rw-r--r--PKGBUILD3
2 files changed, 148 insertions, 0 deletions
diff --git a/0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch b/0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch
new file mode 100644
index 0000000..b6d19c3
--- /dev/null
+++ b/0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch
@@ -0,0 +1,145 @@
+From 45fc8773f47b7cbe56caab0e14abf26d1e044e63 Mon Sep 17 00:00:00 2001
+From: Filipe Manana <fdmanana@suse.com>
+Date: Wed, 11 Sep 2019 17:42:00 +0100
+Subject: Btrfs: fix unwritten extent buffers and hangs on future writeback
+ attempts
+
+The lock_extent_buffer_io() returns 1 to the caller to tell it everything
+went fine and the callers needs to start writeback for the extent buffer
+(submit a bio, etc), 0 to tell the caller everything went fine but it does
+not need to start writeback for the extent buffer, and a negative value if
+some error happened.
+
+When it's about to return 1 it tries to lock all pages, and if a try lock
+on a page fails, and we didn't flush any existing bio in our "epd", it
+calls flush_write_bio(epd) and overwrites the return value of 1 to 0 or
+an error. The page might have been locked elsewhere, not with the goal
+of starting writeback of the extent buffer, and even by some code other
+than btrfs, like page migration for example, so it does not mean the
+writeback of the extent buffer was already started by some other task,
+so returning a 0 tells the caller (btree_write_cache_pages()) to not
+start writeback for the extent buffer. Note that epd might currently have
+either no bio, so flush_write_bio() returns 0 (success) or it might have
+a bio for another extent buffer with a lower index (logical address).
+
+Since we return 0 with the EXTENT_BUFFER_WRITEBACK bit set on the
+extent buffer and writeback is never started for the extent buffer,
+future attempts to writeback the extent buffer will hang forever waiting
+on that bit to be cleared, since it can only be cleared after writeback
+completes. Such hang is reported with a trace like the following:
+
+ [49887.347053] INFO: task btrfs-transacti:1752 blocked for more than 122 seconds.
+ [49887.347059] Not tainted 5.2.13-gentoo #2
+ [49887.347060] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
+ [49887.347062] btrfs-transacti D 0 1752 2 0x80004000
+ [49887.347064] Call Trace:
+ [49887.347069] ? __schedule+0x265/0x830
+ [49887.347071] ? bit_wait+0x50/0x50
+ [49887.347072] ? bit_wait+0x50/0x50
+ [49887.347074] schedule+0x24/0x90
+ [49887.347075] io_schedule+0x3c/0x60
+ [49887.347077] bit_wait_io+0x8/0x50
+ [49887.347079] __wait_on_bit+0x6c/0x80
+ [49887.347081] ? __lock_release.isra.29+0x155/0x2d0
+ [49887.347083] out_of_line_wait_on_bit+0x7b/0x80
+ [49887.347084] ? var_wake_function+0x20/0x20
+ [49887.347087] lock_extent_buffer_for_io+0x28c/0x390
+ [49887.347089] btree_write_cache_pages+0x18e/0x340
+ [49887.347091] do_writepages+0x29/0xb0
+ [49887.347093] ? kmem_cache_free+0x132/0x160
+ [49887.347095] ? convert_extent_bit+0x544/0x680
+ [49887.347097] filemap_fdatawrite_range+0x70/0x90
+ [49887.347099] btrfs_write_marked_extents+0x53/0x120
+ [49887.347100] btrfs_write_and_wait_transaction.isra.4+0x38/0xa0
+ [49887.347102] btrfs_commit_transaction+0x6bb/0x990
+ [49887.347103] ? start_transaction+0x33e/0x500
+ [49887.347105] transaction_kthread+0x139/0x15c
+
+So fix this by not overwriting the return value (ret) with the result
+from flush_write_bio(). We also need to clear the EXTENT_BUFFER_WRITEBACK
+bit in case flush_write_bio() returns an error, otherwise it will hang
+any future attempts to writeback the extent buffer, and undo all work
+done before (set back EXTENT_BUFFER_DIRTY, etc).
+
+This is a regression introduced in the 5.2 kernel.
+
+Fixes: 2e3c25136adfb ("btrfs: extent_io: add proper error handling to lock_extent_buffer_for_io()")
+Fixes: f4340622e0226 ("btrfs: extent_io: Move the BUG_ON() in flush_write_bio() one level up")
+Reported-by: Zdenek Sojka <zsojka@seznam.cz>
+Link: https://lore.kernel.org/linux-btrfs/GpO.2yos.3WGDOLpx6t%7D.1TUDYM@seznam.cz/T/#u
+Reported-by: Stefan Priebe - Profihost AG <s.priebe@profihost.ag>
+Link: https://lore.kernel.org/linux-btrfs/5c4688ac-10a7-fb07-70e8-c5d31a3fbb38@profihost.ag/T/#t
+Reported-by: Drazen Kacar <drazen.kacar@oradian.com>
+Link: https://lore.kernel.org/linux-btrfs/DB8PR03MB562876ECE2319B3E579590F799C80@DB8PR03MB5628.eurprd03.prod.outlook.com/
+Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=204377
+Signed-off-by: Filipe Manana <fdmanana@suse.com>
+---
+ fs/btrfs/extent_io.c | 35 ++++++++++++++++++++++++++---------
+ 1 file changed, 26 insertions(+), 9 deletions(-)
+
+diff --git a/fs/btrfs/extent_io.c b/fs/btrfs/extent_io.c
+index db337e53aab3..93900ff87df7 100644
+--- a/fs/btrfs/extent_io.c
++++ b/fs/btrfs/extent_io.c
+@@ -3591,6 +3591,13 @@ void wait_on_extent_buffer_writeback(struct extent_buffer *eb)
+ TASK_UNINTERRUPTIBLE);
+ }
+
++static void end_extent_buffer_writeback(struct extent_buffer *eb)
++{
++ clear_bit(EXTENT_BUFFER_WRITEBACK, &eb->bflags);
++ smp_mb__after_atomic();
++ wake_up_bit(&eb->bflags, EXTENT_BUFFER_WRITEBACK);
++}
++
+ /*
+ * Lock eb pages and flush the bio if we can't the locks
+ *
+@@ -3662,8 +3669,11 @@ static noinline_for_stack int lock_extent_buffer_for_io(struct extent_buffer *eb
+
+ if (!trylock_page(p)) {
+ if (!flush) {
+- ret = flush_write_bio(epd);
+- if (ret < 0) {
++ int err;
++
++ err = flush_write_bio(epd);
++ if (err < 0) {
++ ret = err;
+ failed_page_nr = i;
+ goto err_unlock;
+ }
+@@ -3678,16 +3688,23 @@ err_unlock:
+ /* Unlock already locked pages */
+ for (i = 0; i < failed_page_nr; i++)
+ unlock_page(eb->pages[i]);
++ /*
++ * Clear EXTENT_BUFFER_WRITEBACK and wake up anyone waiting on it.
++ * Also set back EXTENT_BUFFER_DIRTY so future attempts to this eb can
++ * be made and undo everything done before.
++ */
++ btrfs_tree_lock(eb);
++ spin_lock(&eb->refs_lock);
++ set_bit(EXTENT_BUFFER_DIRTY, &eb->bflags);
++ end_extent_buffer_writeback(eb);
++ spin_unlock(&eb->refs_lock);
++ percpu_counter_add_batch(&fs_info->dirty_metadata_bytes, eb->len,
++ fs_info->dirty_metadata_batch);
++ btrfs_clear_header_flag(eb, BTRFS_HEADER_FLAG_WRITTEN);
++ btrfs_tree_unlock(eb);
+ return ret;
+ }
+
+-static void end_extent_buffer_writeback(struct extent_buffer *eb)
+-{
+- clear_bit(EXTENT_BUFFER_WRITEBACK, &eb->bflags);
+- smp_mb__after_atomic();
+- wake_up_bit(&eb->bflags, EXTENT_BUFFER_WRITEBACK);
+-}
+-
+ static void set_btree_ioerr(struct page *page)
+ {
+ struct extent_buffer *eb = (struct extent_buffer *)page->private;
+--
+cgit v1.2.1-1-g437b
+
diff --git a/PKGBUILD b/PKGBUILD
index db77ec4..18f510e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,7 @@ source=(
https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar.{xz,sign}
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
+ 0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch
ck_remove-excess-extraversion.patch
linux-ck-patch-${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-${_ckpatchversion}/${_ckpatch}.xz
graysky_bdver2-hotfix.patch
@@ -57,6 +58,7 @@ sha256sums=('c64d36477fee6a864a734ec417407768e60040a13f144c33208fa9622fd0ce8c'
'SKIP'
'91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
'63e4378e69e2f23ed87af32a4951477a6d82d4ac0de2295db46502c8120da9d9'
+ '940719452e133a7350dd5efea974190af07eb365a6a60d117b76efca4ca53e7a'
'152c551bd03e92d6458b0d9f352c97eb058014ab019fa213167a6f8178bd6d71'
'f1abc13a8d859fbf6350040e45d7f04ad551a6d39f113ba96fbbd820118c0e36'
'c5405139aa0a90a6f68f6a13e066a2bd0600c970f9f525cd3aa114b044a7f73b'
@@ -87,6 +89,7 @@ prepare() {
msg2 "Applying hotfixes"
patch -p1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
patch -p1 -i ../0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
+ patch -p1 -i ../0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch
# ck hotfixes