summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-03-18 09:29:54 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-03-18 09:29:54 -0700
commitba1e9fbe985cba844afbb3c8500c43e0ff59e4b8 (patch)
tree013c37809e2c7fb314893745a75f6b528ec7b417
parentUpdated to 5.5.9 (diff)
downloadlinux-ck-ba1e9fbe985cba844afbb3c8500c43e0ff59e4b8.tar.xz
Updated to 5.5.10
-rw-r--r--0003-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch (renamed from 0004-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch)0
-rw-r--r--0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch39
-rw-r--r--0004-drm_915_Serialise_i915_active_acquire_with__active_retire.patch (renamed from 0005-drm_915_Serialise_i915_active_acquire_with__active_retire.patch)0
-rw-r--r--0005-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch (renamed from 0006-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch)0
-rw-r--r--0006-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch (renamed from 0007-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch)0
-rw-r--r--0007-drm-i915-gem-Try-to-flush-pending-unbind-events.patch (renamed from 0008-drm-i915-gem-Try-to-flush-pending-unbind-events.patch)0
-rw-r--r--0008-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch (renamed from 0009-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch)0
-rw-r--r--0009-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch (renamed from 0010-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch)0
-rw-r--r--0010-drm-i915-Introduce-a-vma.kref.patch (renamed from 0011-drm-i915-Introduce-a-vma.kref.patch)0
-rw-r--r--PKGBUILD39
10 files changed, 18 insertions, 60 deletions
diff --git a/0004-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch b/0003-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
index 15688c8..15688c8 100644
--- a/0004-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
+++ b/0003-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
diff --git a/0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch b/0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch
deleted file mode 100644
index f9830bb..0000000
--- a/0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 0e6fb279c7fc6fc818942f668f731946286c959c Mon Sep 17 00:00:00 2001
-From: Dan Moulding <dmoulding@me.com>
-Date: Tue, 28 Jan 2020 02:31:07 -0700
-Subject: iwlwifi: mvm: Do not require PHY_SKU NVM section for 3168 devices
-
-The logic for checking required NVM sections was recently fixed in
-commit b3f20e098293 ("iwlwifi: mvm: fix NVM check for 3168
-devices"). However, with that fixed the else is now taken for 3168
-devices and within the else clause there is a mandatory check for the
-PHY_SKU section. This causes the parsing to fail for 3168 devices.
-
-The PHY_SKU section is really only mandatory for the IWL_NVM_EXT
-layout (the phy_sku parameter of iwl_parse_nvm_data is only used when
-the NVM type is IWL_NVM_EXT). So this changes the PHY_SKU section
-check so that it's only mandatory for IWL_NVM_EXT.
-
-Fixes: b3f20e098293 ("iwlwifi: mvm: fix NVM check for 3168 devices")
-Signed-off-by: Dan Moulding <dmoulding@me.com>
----
- drivers/net/wireless/intel/iwlwifi/mvm/nvm.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/nvm.c b/drivers/net/wireless/intel/iwlwifi/mvm/nvm.c
-index 46128a2a9c6e..e98ce380c7b9 100644
---- a/drivers/net/wireless/intel/iwlwifi/mvm/nvm.c
-+++ b/drivers/net/wireless/intel/iwlwifi/mvm/nvm.c
-@@ -308,7 +308,8 @@ iwl_parse_nvm_sections(struct iwl_mvm *mvm)
- }
-
- /* PHY_SKU section is mandatory in B0 */
-- if (!mvm->nvm_sections[NVM_SECTION_TYPE_PHY_SKU].data) {
-+ if (mvm->trans->cfg->nvm_type == IWL_NVM_EXT &&
-+ !mvm->nvm_sections[NVM_SECTION_TYPE_PHY_SKU].data) {
- IWL_ERR(mvm,
- "Can't parse phy_sku in B0, empty sections\n");
- return NULL;
---
-cgit v1.2.2-1-gc45e
-
diff --git a/0005-drm_915_Serialise_i915_active_acquire_with__active_retire.patch b/0004-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
index 937adac..937adac 100644
--- a/0005-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
+++ b/0004-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
diff --git a/0006-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch b/0005-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
index 3afe243..3afe243 100644
--- a/0006-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
+++ b/0005-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
diff --git a/0007-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch b/0006-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
index 9887e67..9887e67 100644
--- a/0007-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
+++ b/0006-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
diff --git a/0008-drm-i915-gem-Try-to-flush-pending-unbind-events.patch b/0007-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
index 52196eb..52196eb 100644
--- a/0008-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
+++ b/0007-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
diff --git a/0009-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch b/0008-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
index 2719884..2719884 100644
--- a/0009-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
+++ b/0008-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
diff --git a/0010-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch b/0009-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
index 9db4525..9db4525 100644
--- a/0010-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
+++ b/0009-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
diff --git a/0011-drm-i915-Introduce-a-vma.kref.patch b/0010-drm-i915-Introduce-a-vma.kref.patch
index 2ad022b..2ad022b 100644
--- a/0011-drm-i915-Introduce-a-vma.kref.patch
+++ b/0010-drm-i915-Introduce-a-vma.kref.patch
diff --git a/PKGBUILD b/PKGBUILD
index 793eb5c..1838bb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@
pkgbase=linux-ck
_supver=5
_majver=5
-_minver=9
+_minver=10
_gccpatchver='20191217'
_gccpatchger='9.1'
_gccpatchker='5.5'
@@ -45,15 +45,14 @@ source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
- 0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch
- 0004-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
- 0005-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
- 0006-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
- 0007-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
- 0008-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
- 0009-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
- 0010-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
- 0011-drm-i915-Introduce-a-vma.kref.patch
+ 0003-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
+ 0004-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
+ 0005-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
+ 0006-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
+ 0007-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
+ 0008-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
+ 0009-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
+ 0010-drm-i915-Introduce-a-vma.kref.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
graysky_bdver2-hotfix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
@@ -66,11 +65,10 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('0f9c4e49bd6d88be460609013fc2dfb6dc0d5999b3cd2321d9953ed42a97d373c04ecc21d4b28f2873f0086938910deeceadf3334f52920483844057eae4851c'
+b2sums=('9498865279ca942aa3f9788ccabbb4e0b5e2ac67e0fac75c662757b276eea87c61dd34d6a0e64ab309cec58e0a0374622593ca7af961063488cef7705c58e774'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
'2e822cf7d4ff8b7458e22d3ce110fd8534e17a9aac2feace41c591f70697e1fab7bd9ce307c60a6361fbe525d10dab74c8b76fcb5276cd27f6e945f8fdfcc25c'
- '1ae8107eb3d56db5b61fa07a35181232cc0be6c66f10b313a2f6b473bdbb33a42d8be3660413eef5321e08a775cda47260775174f74b803f3e66cdb890b9c6f3'
'd8027cd96a447ea0987a67f3e65d157bb3d396069a944b140610f74c663677fe45e171e96a92dfd5eda8f71a5c715fd8114ee0e60b7620bc401a2a548bcf83cc'
'df41200d86f1fd493861d4b4a091ec5f853ce7668ec9712f57e574ce2c1a94c7054ec8abcdf947086e5f98b0cdde73523521552536c91373dacdd10c4ecf4c1a'
'f4d5f82c5deb981f475fd18a408e23b5f170e23c7a49c3563171e55abd78c07c475a7a9c67850c4a3665ce3447cd7b5fb3171e47af8cd8077822f2a6679cfd9b'
@@ -104,15 +102,14 @@ prepare() {
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
patch -p1 -i ../0002-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
- patch -p1 -i ../0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch
- patch -p1 -i ../0004-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
- patch -p1 -i ../0005-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
- patch -p1 -i ../0006-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
- patch -p1 -i ../0007-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
- patch -p1 -i ../0008-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
- patch -p1 -i ../0009-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
- patch -p1 -i ../0010-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
- patch -p1 -i ../0011-drm-i915-Introduce-a-vma.kref.patch
+ patch -p1 -i ../0003-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
+ patch -p1 -i ../0004-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
+ patch -p1 -i ../0005-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
+ patch -p1 -i ../0006-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
+ patch -p1 -i ../0007-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
+ patch -p1 -i ../0008-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
+ patch -p1 -i ../0009-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
+ patch -p1 -i ../0010-drm-i915-Introduce-a-vma.kref.patch
# fix naming schema in EXTRAVERSION of ck patch set