diff options
author | jc_gargma <jc_gargma@iserlohn-fortress.net> | 2020-05-17 13:34:54 -0700 |
---|---|---|
committer | jc_gargma <jc_gargma@iserlohn-fortress.net> | 2020-05-17 13:34:54 -0700 |
commit | 2bb5855011f83a03e028bed2f4efec78378a5ce1 (patch) | |
tree | c13a1725b2968c30a9dfff40fd79d4f3d4f6833a /PKGBUILD | |
parent | Updated to 5.6.13 (diff) | |
download | linux-ck-2bb5855011f83a03e028bed2f4efec78378a5ce1.tar.xz |
Add toggle to ease disabling custom config
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 14 |
1 files changed, 10 insertions, 4 deletions
@@ -16,6 +16,8 @@ # Arch version enables VMware and HyperV # Arch version builds documentation +_custom=1 + pkgbase=linux-ck _supver=5 _majver=6 @@ -134,8 +136,10 @@ prepare() { echo "Setting config..." # we are in src/linux-x.yy.zz, looking for a config next to the pkgbuild - if [ -f ${SRCDEST}/config.ck.previous ]; then - cp ${SRCDEST}/config.ck.previous .config + if [ "$_custom" == "1" ]; then + if [ -f ${SRCDEST}/config.ck.previous ]; then + cp ${SRCDEST}/config.ck.previous .config + fi else cp ../config .config fi @@ -166,8 +170,10 @@ prepare() { cat ../version.temp | tr -d "\n" > version # back up the config - echo "Backing up config..." - cp .config ${SRCDEST}/config.ck.previous + if [ "$_custom" == "1" ]; then + echo "Backing up config..." + cp .config ${SRCDEST}/config.ck.previous + fi echo "Prepared $pkgbase version $(<version)" } |