summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
-rw-r--r--zfs.patch20
2 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22728f2..3e048c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,6 +43,7 @@ options=('!strip')
_srcname=linux-${pkgver}
source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
+ zfs.patch
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
0003-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
@@ -69,6 +70,7 @@ validpgpkeys=(
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
b2sums=('654024b8aff12a1d15a8cc2e3698f98707bc5a7a5825d592e7cc047c1222d8561403013068c08e35e408364bd40575d749503dd5cad189594d45b80a295d13a0'
'SKIP'
+ '4b982e16e3fee2c2c40db08d67a6cc794c27308c4b513a9baf909c5ea40e3be239288ba4c422e8eb58a669646d331e7fd945d7451d1a388f1c68fe3a445aa814'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
'2e822cf7d4ff8b7458e22d3ce110fd8534e17a9aac2feace41c591f70697e1fab7bd9ce307c60a6361fbe525d10dab74c8b76fcb5276cd27f6e945f8fdfcc25c'
'd8027cd96a447ea0987a67f3e65d157bb3d396069a944b140610f74c663677fe45e171e96a92dfd5eda8f71a5c715fd8114ee0e60b7620bc401a2a548bcf83cc'
@@ -116,6 +118,8 @@ prepare() {
patch -p1 -i ../0010-drm-i915-Introduce-a-vma.kref.patch
patch -p1 -i ../0011-iwlwifi-dont-send-GEO_TX_POWER_LIMIT-if-no-wgds-table.patch
+ msg2 "Fixing ZFS compatibility"
+ patch -p1 -i ../zfs.patch
# fix naming schema in EXTRAVERSION of ck patch set
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}"
diff --git a/zfs.patch b/zfs.patch
new file mode 100644
index 0000000..7df5914
--- /dev/null
+++ b/zfs.patch
@@ -0,0 +1,20 @@
+--- a/kernel/rcu/tree_plugin.h
++++ b/kernel/rcu/tree_plugin.h
+@@ -360,7 +360,7 @@
+ WARN_ON_ONCE(current->rcu_read_lock_nesting > RCU_NEST_PMAX);
+ barrier(); /* critical section after entry code. */
+ }
+-EXPORT_SYMBOL_GPL(__rcu_read_lock);
++EXPORT_SYMBOL(__rcu_read_lock);
+
+ /*
+ * Preemptible RCU implementation for rcu_read_unlock().
+@@ -390,7 +390,7 @@
+ WARN_ON_ONCE(rrln < 0 && rrln > RCU_NEST_NMAX);
+ }
+ }
+-EXPORT_SYMBOL_GPL(__rcu_read_unlock);
++EXPORT_SYMBOL(__rcu_read_unlock);
+
+ /*
+ * Advance a ->blkd_tasks-list pointer to the next entry, instead