diff options
-rw-r--r-- | PKGBUILD | 14 |
1 files changed, 10 insertions, 4 deletions
@@ -16,6 +16,8 @@ # Arch version enables VMware and HyperV # Arch version builds documentation +_custom=1 + pkgbase=linux-ck _supver=5 _majver=6 @@ -134,8 +136,10 @@ prepare() { echo "Setting config..." # we are in src/linux-x.yy.zz, looking for a config next to the pkgbuild - if [ -f ${SRCDEST}/config.ck.previous ]; then - cp ${SRCDEST}/config.ck.previous .config + if [ "$_custom" == "1" ]; then + if [ -f ${SRCDEST}/config.ck.previous ]; then + cp ${SRCDEST}/config.ck.previous .config + fi else cp ../config .config fi @@ -166,8 +170,10 @@ prepare() { cat ../version.temp | tr -d "\n" > version # back up the config - echo "Backing up config..." - cp .config ${SRCDEST}/config.ck.previous + if [ "$_custom" == "1" ]; then + echo "Backing up config..." + cp .config ${SRCDEST}/config.ck.previous + fi echo "Prepared $pkgbase version $(<version)" } |