summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83c1aed..bfc151c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ _custom=1
pkgbase=linux-ck
_supver=5
_majver=10
-_minver=4
+_minver=5
_gccpatchver='20201113'
_gccpatchger='10.1'
_gccpatchker='5.8'
@@ -41,7 +41,6 @@ license=(GPL2)
makedepends=(
bc kmod libelf pahole cpio perl tar xz
)
-#provides=('linux-ck')
conflicts=('linux-libre-ck')
options=('!strip')
_srcname=linux-${pkgver}
@@ -51,9 +50,10 @@ source=(
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-Bluetooth-Fix-attempting-to-set-RPA-timeout-when-unsupported.patch
0003-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
- 0004-drm-amd-display-Add-get_dig_frontend-implementation-for-DCEx.patch
- 0005-btrfs-Fix-500-2000-performance-regression-w-5.10.patch
- 0006-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
+ 0004-btrfs-Fix-500-2000-performance-regression-w-5.10.patch
+ 0005-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
+ 0006-ALSA-hda-hdmi-fix-incorrect-mutex-unlock-in-silent_stream_disable.patch
+ 0007-Revert-drm-amd-display-Fix-memory-leaks-in-S3-resume.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
@@ -64,15 +64,16 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('57f6d719451aacfd298452703ae02e6188885500e8cdf18fffa6b9967b0934a23cd378ab4c49b76ccb2f7a9012d6aa7ff1349d488cb31e40924be2f27b244cec'
+b2sums=('25b71eb091ea6526a7ebfef5bc201b76d612e5138b6b3caa708f90e76196c30d1865c223e2084a118a3883a9620d47c9576b1ab7db2c8d9c0f204dda7c640eab'
'SKIP'
- 'e76782869b153d9d41adce369469e1271fd1097ad87e1887da784ac189dd2a57d2c15b4a0d2bc139c46eddfc2e5d74df50386ebfa9793f68190fbc5c77203b10'
+ 'a1f82af8c657988680850a065e935cb33afa01f7db7791a47719271c9f2e3e99686402c245fe7fc2705e5101317a617f8e0c9fbdf0cdcf9b02469804deb71c5a'
'2f9195675270d79d735a3aaec25887c2f80b76eae98be8fcc5fd59ab71d925c5ee20ec5e2a015deb68b61bc2cc7f56f546a22cb96ee038e2e24c2c9dd5c3f79f'
'92b212fc863b86e795ce4b122372ebe7feae04e31a39b7edcf9f7f25552f936ad1de4b2c7a226feab9d61868a8590550c39c2bd893f4bdabc62a750fab9cc391'
'd8297e09f552a2d6bb24c2ba10481fd2b407057f3b24278e72a89233473460d339c83838791989773623178b5af80588fb4c484da2931f1040e313cce7ceca00'
- '67735bed50180fc9145ea5fb59f8b404eb71d3a356378eddf04cdc29be0f0031d4666bcb2f2e70de3775f3c1859f9e550f083178fb9d6bea8b437d9f0f12c53f'
'b00c189e803e9469cece5906af28f086b10cfb228eec694b95a47625ecbd345a443609349f4fda5b340ef5e9834a41c5cae60400cf8fbdd1c23b6cb24e17dbe3'
'15d9b32ff1ad4c897b097173de259cdb89bbbf6ab0230faf4557eca511a59c1f2c76b85be30d25cf9534f91e1af43e72d072bc82dbf2219eadf772822f573d38'
+ 'f5cebaad0bc7188a88444ce3b07f80e98414422d2cc18c251698f8694772ed39a4e22b3fe6702aa21dc4764ff727e4fbebafb501e260b52a36c9feef0fe8537a'
+ '6db620d44c908f14fec4dd74b345ee2829fff1fad8783deb3c31cc9c4e298c269711dcc478dfd72c72a5d8b36447d6ff892589eb322bf0811810cd861805d3eb'
'067f3389124fdd937ca69e9e9568b1b3194791960a093e81037051eb6d25e80b40bf7f60c61373ac9e92bff9db760766009b1e6f9ee8429a883bb7fce2d60f8a'
'7f1eb5938472f57748216bd00e0c875feab99fc1c5cb89babfea467ee30ca5c8e9fc5a691efe2e602bef1ea79820c5383822d7cec354b48d23321ccda8ee8127'
'b6ef77035611139fa9a6d5b8d30570e2781bb4da483bb569884b0bd0129b62e0b82a5a6776fefe43fee801c70d39de1ea4d4c177f7cedd5ac135e3c64f7b895a'
@@ -97,9 +98,10 @@ prepare() {
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
patch -p1 -i ../0002-Bluetooth-Fix-attempting-to-set-RPA-timeout-when-unsupported.patch
patch -p1 -i ../0003-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
- patch -p1 -i ../0004-drm-amd-display-Add-get_dig_frontend-implementation-for-DCEx.patch
- patch -p1 -i ../0005-btrfs-Fix-500-2000-performance-regression-w-5.10.patch
- patch -p1 -i ../0006-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
+ patch -p1 -i ../0004-btrfs-Fix-500-2000-performance-regression-w-5.10.patch
+ patch -p1 -i ../0005-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
+ patch -p1 -i ../0006-ALSA-hda-hdmi-fix-incorrect-mutex-unlock-in-silent_stream_disable.patch
+ patch -p1 -i ../0007-Revert-drm-amd-display-Fix-memory-leaks-in-S3-resume.patch
# fix naming schema in EXTRAVERSION of ck patch set