summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 25 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0272b0a..83c1aed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@
# Arch version is 300 Hz
# Arch version does not disable lockdown eee
# Arch version does not disable hdcp
+# Arch version does not disable IME/PSP/TEE/SEV
# Arch version allows insecure filesystems
# Arch version enables staging drivers
# Arch version enables ISDN and Infiniband
@@ -20,8 +21,8 @@ _custom=1
pkgbase=linux-ck
_supver=5
-_majver=9
-_minver=16
+_majver=10
+_minver=4
_gccpatchver='20201113'
_gccpatchger='10.1'
_gccpatchker='5.8'
@@ -46,34 +47,36 @@ options=('!strip')
_srcname=linux-${pkgver}
source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
+ config # the main kernel config file
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch
- 0003-Bluetooth-Fix-attempting-to-set-RPA-timeout-when-unsupported.patch
- 0004-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
+ 0002-Bluetooth-Fix-attempting-to-set-RPA-timeout-when-unsupported.patch
+ 0003-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
+ 0004-drm-amd-display-Add-get_dig_frontend-implementation-for-DCEx.patch
+ 0005-btrfs-Fix-500-2000-performance-regression-w-5.10.patch
+ 0006-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
raid6-default-algo.patch
- config # the main kernel config file
- sphinx-workaround.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('7eff5747a1339bf0aa2e37718a37a17d994facf6407e7a37e3f055452ac971bda11cf6e047d5c159af98897ec7c719baf0eb6549d4472044f704d44319ddaadc'
+b2sums=('57f6d719451aacfd298452703ae02e6188885500e8cdf18fffa6b9967b0934a23cd378ab4c49b76ccb2f7a9012d6aa7ff1349d488cb31e40924be2f27b244cec'
'SKIP'
- 'c1e9177debee553e03873dff9293e7a21a53297fc4b3df8b9f54a8839cf1c7d6803945fc7d64676fe8c04cb54ef331b59c4348fbc9915060162177be503d9e96'
- '647c9a8580f3f716e39e0bc086acff1fc34d3592011c931c8e00259c395cdd7fff94d71b963cd87850b8e0f67dd31b719ce4f1cc855e553e42a5694ff6bd53dc'
- '6729b31b33dc2dc8ee6222ae3782d31bd567e002ee9655f7453ec80c6deda247153b59b9c71f0c60095e491165ab1c8c7bdbff5cc538e9ea920bec889870edec'
- '5561976e7521ddf13d3682d7c25658a29b33e5065a01ca7909605cb1a9f479ebe39f9fb8057eb430c73dcac1b8f815273017465b63a8cbae933c9c85d700ec17'
- 'c19099ad66168db4608dee44e1913c07c035bc002a91267abc2e1eadf1788ddb5be3b17e3fdfeddcba96526dfa2b9fcc43a5dd0f8236d94c864e6477924a6718'
+ 'e76782869b153d9d41adce369469e1271fd1097ad87e1887da784ac189dd2a57d2c15b4a0d2bc139c46eddfc2e5d74df50386ebfa9793f68190fbc5c77203b10'
+ '2f9195675270d79d735a3aaec25887c2f80b76eae98be8fcc5fd59ab71d925c5ee20ec5e2a015deb68b61bc2cc7f56f546a22cb96ee038e2e24c2c9dd5c3f79f'
+ '92b212fc863b86e795ce4b122372ebe7feae04e31a39b7edcf9f7f25552f936ad1de4b2c7a226feab9d61868a8590550c39c2bd893f4bdabc62a750fab9cc391'
+ 'd8297e09f552a2d6bb24c2ba10481fd2b407057f3b24278e72a89233473460d339c83838791989773623178b5af80588fb4c484da2931f1040e313cce7ceca00'
+ '67735bed50180fc9145ea5fb59f8b404eb71d3a356378eddf04cdc29be0f0031d4666bcb2f2e70de3775f3c1859f9e550f083178fb9d6bea8b437d9f0f12c53f'
+ 'b00c189e803e9469cece5906af28f086b10cfb228eec694b95a47625ecbd345a443609349f4fda5b340ef5e9834a41c5cae60400cf8fbdd1c23b6cb24e17dbe3'
+ '15d9b32ff1ad4c897b097173de259cdb89bbbf6ab0230faf4557eca511a59c1f2c76b85be30d25cf9534f91e1af43e72d072bc82dbf2219eadf772822f573d38'
+ '067f3389124fdd937ca69e9e9568b1b3194791960a093e81037051eb6d25e80b40bf7f60c61373ac9e92bff9db760766009b1e6f9ee8429a883bb7fce2d60f8a'
'7f1eb5938472f57748216bd00e0c875feab99fc1c5cb89babfea467ee30ca5c8e9fc5a691efe2e602bef1ea79820c5383822d7cec354b48d23321ccda8ee8127'
'b6ef77035611139fa9a6d5b8d30570e2781bb4da483bb569884b0bd0129b62e0b82a5a6776fefe43fee801c70d39de1ea4d4c177f7cedd5ac135e3c64f7b895a'
- 'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
- '0d2c8f72afd5fd5bdd0191e5eddb51e24ab0b2a49019c53a89ce464933f4b621efe4ff5992a6b04f44c77baf6a51e7ac2ff8573d518ed1bb4f6bc692d51b8cfa'
- 'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95')
+ 'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a')
#export KBUILD_BUILD_HOST=arc4linux
export KBUILD_BUILD_USER=$pkgbase
@@ -92,10 +95,11 @@ prepare() {
# Hotfixes
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- patch -p1 -i ../0002-Bluetooth-Fix-LL-PRivacy-BLE-device-fails-to-connect.patch
- patch -p1 -i ../0003-Bluetooth-Fix-attempting-to-set-RPA-timeout-when-unsupported.patch
- patch -p1 -i ../0004-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
- patch -p1 -i ../sphinx-workaround.patch
+ patch -p1 -i ../0002-Bluetooth-Fix-attempting-to-set-RPA-timeout-when-unsupported.patch
+ patch -p1 -i ../0003-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
+ patch -p1 -i ../0004-drm-amd-display-Add-get_dig_frontend-implementation-for-DCEx.patch
+ patch -p1 -i ../0005-btrfs-Fix-500-2000-performance-regression-w-5.10.patch
+ patch -p1 -i ../0006-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
# fix naming schema in EXTRAVERSION of ck patch set
@@ -275,6 +279,7 @@ _package-headers() {
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
#echo "Stripping vmlinux..."
#strip -v $STRIP_STATIC "$builddir/vmlinux"