summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0fa2fb..d03b81f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@
pkgbase=linux-ck
_majver=5.2
-_minver=14
+_minver=15
if [ "$_minver" == "0" ]; then
pkgver=${_majver}
else
@@ -28,7 +28,7 @@ _ckpatchversion=ck1
_ckpatch="patch-${_majver}-${_ckpatchversion}"
_gccpatchver='20190822'
_srcname=linux-${pkgver}
-pkgrel=2
+pkgrel=1
url='https://kernel.org'
#url='http://ck.kolivas.org/patches/'
arch=('x86_64')
@@ -40,10 +40,7 @@ conflicts=('linux-libre')
options=('!strip')
source=(
https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar.{xz,sign}
- 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
- 0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch
- ck_remove-excess-extraversion.patch
+ 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
linux-ck-patch-${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-${_ckpatchversion}/${_ckpatch}.xz
graysky_bdver2-hotfix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
@@ -54,18 +51,15 @@ source=(
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('c64d36477fee6a864a734ec417407768e60040a13f144c33208fa9622fd0ce8c'
+sha256sums=('eb561009da8106b463b1e1a16ab0f75cdef564784f49177148f5f92c32380c4a'
'SKIP'
- '91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
- '63e4378e69e2f23ed87af32a4951477a6d82d4ac0de2295db46502c8120da9d9'
- '940719452e133a7350dd5efea974190af07eb365a6a60d117b76efca4ca53e7a'
- '152c551bd03e92d6458b0d9f352c97eb058014ab019fa213167a6f8178bd6d71'
+ 'e862ecd2cb0b20e1859ec3e47616457a9a3acb111cd5a86094f9ed1dbd7f42ac'
'f1abc13a8d859fbf6350040e45d7f04ad551a6d39f113ba96fbbd820118c0e36'
'c5405139aa0a90a6f68f6a13e066a2bd0600c970f9f525cd3aa114b044a7f73b'
'8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
'0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
- '8f2974e3c204c6a7c0a64e1048ec56cb8aebb65d6383453008dfe8e3049e177e'
+ 'eb5aa60f85a2fbf62cff64215bc819913e160e48b39d0a03f72542db5d4d33ad'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -85,16 +79,14 @@ prepare() {
# patch -Np1 < ../patch-${_majver}-${_pkgver}
# fi
+
# Hotfixes
msg2 "Applying hotfixes"
- patch -p1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- patch -p1 -i ../0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
- patch -p1 -i ../0003-Btrfs-fix-unwritten-extent-buffers-and-hangs-on-future-writeback-attempts.patch
+ patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
- # ck hotfixes
- msg2 "Applying ck patch hotfixes"
- patch -p1 -i ../ck_remove-excess-extraversion.patch "$srcdir/linux-ck-patch-5.2-ck1"
+ # fix naming schema in EXTRAVERSION of ck patch set
+ sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../linux-ck-patch-${_majver}-${_ckpatchversion}"
# ck patch
msg2 "Applying ck patch"
@@ -133,6 +125,13 @@ prepare() {
cp ../config.x86_64 .config
fi
+ # https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
+ sed -i -e 's/# CONFIG_PSI_DEFAULT_DISABLED is not set/CONFIG_PSI_DEFAULT_DISABLED=y/' ./.config
+
+ # https://bbs.archlinux.org/viewtopic.php?pid=1863567#p1863567
+ sed -i -e 's/CONFIG_LATENCYTOP=y/# CONFIG_LATENCYTOP is not set/' \
+ -i -e 's/CONFIG_SCHED_DEBUG=y/# CONFIG_SCHED_DEBUG is not set/' ./.config
+
make olddefconfig
make menuconfig