summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD136
1 files changed, 70 insertions, 66 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb56821..274b3e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
pkgbase=linux-ck
_supver=5
_majver=4
-_minver=12
+_minver=13
_gccpatchver='20190822'
_ckpatchversion=ck1
if [ "$_minver" == "0" ]; then
@@ -39,20 +39,21 @@ options=('!strip')
_srcname=linux-${pkgver}
source=(
https://www.kernel.org/pub/linux/kernel/v${_supver}.x/${_srcname}.tar.{xz,sign}
- 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
+ 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-lib-devres-add-a-helper-function-for-ioremap_uc.patch
0003-mfd-intel-lpss-Use-devm_ioremap_uc-for-MMIO.patch
- 0004-PCI-pciehp-Do-not-disable-interrupt-twice-on-suspend.patch
- 0005-PCI-pciehp-Prevent-deadlock-on-disconnect.patch
- 0006-ACPI-PM-s2idle-Rework-ACPI-events-synchronization.patch
- 0007-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
- 0008-drm-i915-save-AUD_FREQ_CNTRL-state-at-audio-domain-suspend.patch
- 0009-drm-i915-Fix-audio-power-up-sequence-for-gen10-display.patch
- 0010-drm-i915-extend-audio-CDCLK-2BCLK-constraint-to-more-platforms.patch
- 0011-drm-915-Limit-audio-CDCLK-2BCLK-constraint-back-to-GLK-only.patch
- 0012-pinctrl-sunrisepoint-Add-missing-Interrupt-Status-register-offset.patch
- 0013-Revert-iwlwifi-mvm-fix-scan-config-command-size.patch
- 0014-e1000e-Revert-e1000e-Make-watchdog-use-delayed-work.patch
+ 0004-PCI-pciehp-Prevent-deadlock-on-disconnect.patch
+ 0005-ACPI-PM-s2idle-Rework-ACPI-events-synchronization.patch
+ 0006-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
+ 0007-drm-i915-save-AUD_FREQ_CNTRL-state-at-audio-domain-s.patch
+ 0008-drm-i915-Fix-audio-power-up-sequence-for-gen10-displ.patch
+ 0009-drm-i915-extend-audio-CDCLK-2-BCLK-constraint-to-mor.patch
+ 0010-drm-i915-Limit-audio-CDCLK-2-BCLK-constraint-back-to.patch
+ 0011-pinctrl-sunrisepoint-Add-missing-Interrupt-Status-re.patch
+ 0012-Revert-iwlwifi-mvm-fix-scan-config-command-size.patch
+ 0013-e1000e-Revert-e1000e-Make-watchdog-use-delayed-work.patch
+ 0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch
+ 0015-ptp-free-ptp-device-pin-descriptors-properly.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
graysky_bdver2-hotfix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
@@ -65,28 +66,29 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('f08d30011b2021724a240f45a4d0a92ba01b97d0d2d33ce0d88aeb6dfb0a2e5a532fd55ad0a2ef0e3ec160cb23b351a09b494382e80b0db85bcfe7cfeaa554dd'
+b2sums=('d610a2bf375c9147b26d6e314c1e86b9f32453572c1e8a859be3ac5fa42d7ba647334ef76a92a7e1e61f78fa256692bec3d62003589017840a37947d9d5b1de0'
'SKIP'
- '8e25246725016ac6a1452592b092616aacba744ee6d1f87355b141011e31d91b2faca01494930a8bb4b816f92f86929098cc60bf786bdc68513e7bc572b06226'
- '0e4e01200c6250c6d251d2cb38889e9f488e07b1014ea8c8f81182457cf057ce444b14e21afc786671115ec0b100e3ce9b32a5785c2b0b07b11d956887f477d3'
- 'd3b62df935c6f5379b4c11f455a7231ffbab58857bdd650256499a702e54aaa729348054beb7742b90f145893622538aa4345c117238d46687ef6d07d62655da'
- 'f2d71e3652594d7c23c87a952c40a3c2d394f6a621dce6a19a0463108695c55f5505d9526abb5283b74e3f84ae51283aeaf0e76a78e8e0133b0b07828def1d1d'
- 'bf786a19dd0cc8572880f8339711fa173219b2cb9f44b2a4e48591671770c075706ea6db673ddd2cd49d42bdb2723e0161a704f77c761df5fdf31b033f45b6a0'
- '8083144de9dcf8750a502589625d6d16c2316dfb01dddf6b502dbcf5d1632822ed1cee05e5eb0ecf58cd88726cda84b0ea493c1ab6df3a862886756aa78d540a'
- '7a9081dee4774f8b2f51dcd980bfcd085ead77fb07915026044792bdf1c8831626173471a2c2cac0e1420fe7f23954b9101eab4884c78c33115f096cd5f560e9'
- 'f28183f6fd07ba0e6787e935d56dd683435e0bdd6e04cba717aa5b0da093d40a79a422f3398b813e41d70411cbd664045518050fd9b61a0350e75e36e747c345'
- '7fc476dc0fef4d0a11c3f04c33a0350eae87115dcafcfb96a453112041ba88e1cf5a3535c95069568c849f04c356e2bde0686c8e5ba25be7a781b775f808a43c'
- '9d1ad2023e9ffc92a4ccb6194a858267fbb6286c13784b8b8a2af3d5814abd0e4229409489f8a6bea5157193324dba58553ba03229169809bec73a8cc59c26ba'
- '7d6e7b7c2791971de427b346732c3fa345635db68c84c0b1ac736862fc62da61516975ccd78b28d3df50967d8ae1fe6b3251383733f797c19c1671b8b8a5aa42'
- '782f41ae6352cfc1c47ed54eddcded54969c7d43a326dc2d6593b373b4dc4672bc82a6d938090635dc02ef3b3b74e133a2170c7f9c6fd614641c7cb3b013ff2e'
- 'ae21b49fe1c6fef81aa93282d0a242c196a0378256e890013a05d4e2f3b79ad92526bd1088ab6e44fba511abeabcb328ef58907ab03214d21d2fb88ea702f3e0'
- 'e1da80f3c9197e62223398b717e0c3ecfcdc7f33fa6477a9e8634ae806823c208bd5e05401a0b72a506d8e1df5a5cdf6624ff88926e7042156ee0fb6278e3ca3'
+ '76c34ea8f8d6fafcbb12fa0e01821af5926e60046c37cee9855786b8bfe16b8ac5222d441335aa01b62e7ebfe2805a1175d00d3bc4ee1c2617173934284c4164'
+ '5427a9283a9ccb38a63ba5bd680e331245bd134501ce66e912cb07c250e37810a895f4ae78371db2b0cfcbfcb1bee96daafc0e5c71f40ec9b8643d3a88a80bab'
+ 'fab987c7c77e07ae2db83d148e8d423e6aadbcfc84498a60a6396418c69108c0a38a426eca57c1e94f2540f25cbcd084eafe3d124ac9d0ce2ab4efff28852a16'
+ 'c5cd99138e9436ede9136e5f958a15a10e07ab51e77dc716158b1ff774d9fa06f4ec2b7a1ba171f4ea86c16ea61fb685b54cadb85411b1c7c468d984b495585d'
+ 'd283a69b0577dda72ae5814b3c681ca5f0655692216ce77cccc909903fda037feae35fc545c6d54daa377edb71895cfc4f199a335f3f4dfda3cde90350a627b3'
+ '2328a9bddbb712ffe587a2266d9c6074b4a9e1273b4546e86c56b26dcd7c509398a3e428e6292999bb0297f135683793fa28acfbc4d744962e2ca396943d9ddb'
+ 'a7318e80116cecfe0c31e254c6d52706ce56d202064d9ff851506569ad602ed106bce216facf793a27266a58b372092e5fa4a19b7b4a7380a789874066d91852'
+ 'ab7c15c8a219a7e895b39a10a452005252bb018749607676a7e436263a0876d096a5716c9bcbf30e2ff6bc4e525be22ac3838ab3d363373945d5bf5ce43648d4'
+ 'bb35fce00e121769f4a85c01a799efa7e3eccae8fdd29993d5bbd574a2af50cabeafcf6a9bebf5713223cdb64a53fd7bbf41de7f0a84023531b160e0fe88dc52'
+ '26082d1d89d9a6e44ea29be9056029f4af228cf22d6c4f6c9f32ed552859bcb8982dc57f63bcb216e220590a029800aeade0bf47356f7ef3ebbe9c0261674379'
+ 'aba17d1a3a4638d997c33ea385cfd4ac4008a13f31c026e86342169117aa6b238cdebdc4ddbe234e54c68816386ac0e401ecd9e5b49bd42e1ef60eecdf3ad89a'
+ 'd4878831fa03c17b590001d15ddbbfeb1a8747c961503c26aee330d213c0fbf6c2eab7226456083f52a5fb4b4ffd9bf7b2db741de7c7476a15873f2a8d9f7b74'
+ '76bb50a23b822de85f3381a511b42bb46110a39d31ede81bd168cb708882b93be525576b1805da5383f35f6f18fab817ad195aa870ab75e7775855a150d172a1'
+ '726d89aeb1f5df51cfa395e01edb4b8b36460b1f75611ee921d057dfb28cd2d6c41990bca4b40512b9398e0558c4028845252442d9ec1d8f13847a0ed9903a1d'
+ '00cfbcf17b5f89a0d69f46ea9487088b49b265d360612a777394c69746e13618aff56240dae754111db901891641925b83a8bb95c85c3ee0c11266611d72145c'
'8faff0d2b95eda0b96e8042367634c45c1e823238e99793daeda5614efdc448dfe28172bf13f0d988cf4d5cbb4892089893e0183cd8825de7f54942283f2b5a0'
'1892bd22775eac3bcc4d37f4fd30c95346bf3a0888cbbff57fd614973b525390dff2e315ce35b2e498523cceaab94ff21a80475dee8df3de4dd8fc0fab07d74e'
'0b11c09e01a7480466d5237a8792c941c9af3e8d6584ffd84285cd9569f5355c10879566ce5846ef9263535020c53e1aa6c58100a571b537ccb7f2431baf7996'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
- 'f01a08c06c2888266e5e5929236ad19d03c650fae09f9794840e52692fb93708a2bf88f3a06b4f0ff1ea57d62d6d06d81e5c4ce52f3b55dae1ae71c8d6b736da')
+ '58e09bb87b4780228e6c347171f06a854356e9af21d1bbb3b697848a13c0d196fc8863c6b1343e7ee0b87c43e739132cd8978f31b4aaf04da1cee728b9d1236d')
#export KBUILD_BUILD_HOST=arc4linux
export KBUILD_BUILD_USER=$pkgbase
@@ -97,61 +99,63 @@ prepare() {
# add upstream patch
# if [ "$_minver" != "0" ]; then
-# msg2 "Applying upstream patch"
+# echo "Applying upstream patch"
# patch -Np1 < ../patch-${_supver}.${_majver}-${pkgver}
# fi
# Hotfixes
- msg2 "Applying hotfixes"
- patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
+ echo "Applying hotfixes"
+ patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
patch -p1 -i ../0002-lib-devres-add-a-helper-function-for-ioremap_uc.patch
patch -p1 -i ../0003-mfd-intel-lpss-Use-devm_ioremap_uc-for-MMIO.patch
- patch -p1 -i ../0004-PCI-pciehp-Do-not-disable-interrupt-twice-on-suspend.patch
- patch -p1 -i ../0005-PCI-pciehp-Prevent-deadlock-on-disconnect.patch
- patch -p1 -i ../0006-ACPI-PM-s2idle-Rework-ACPI-events-synchronization.patch
- patch -p1 -i ../0007-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
- patch -p1 -i ../0008-drm-i915-save-AUD_FREQ_CNTRL-state-at-audio-domain-suspend.patch
- patch -p1 -i ../0009-drm-i915-Fix-audio-power-up-sequence-for-gen10-display.patch
- patch -p1 -i ../0010-drm-i915-extend-audio-CDCLK-2BCLK-constraint-to-more-platforms.patch
- patch -p1 -i ../0011-drm-915-Limit-audio-CDCLK-2BCLK-constraint-back-to-GLK-only.patch
- patch -p1 -i ../0012-pinctrl-sunrisepoint-Add-missing-Interrupt-Status-register-offset.patch
- patch -p1 -i ../0013-Revert-iwlwifi-mvm-fix-scan-config-command-size.patch
- patch -p1 -i ../0014-e1000e-Revert-e1000e-Make-watchdog-use-delayed-work.patch
+ patch -p1 -i ../0004-PCI-pciehp-Prevent-deadlock-on-disconnect.patch
+ patch -p1 -i ../0005-ACPI-PM-s2idle-Rework-ACPI-events-synchronization.patch
+ patch -p1 -i ../0006-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
+ patch -p1 -i ../0007-drm-i915-save-AUD_FREQ_CNTRL-state-at-audio-domain-s.patch
+ patch -p1 -i ../0008-drm-i915-Fix-audio-power-up-sequence-for-gen10-displ.patch
+ patch -p1 -i ../0009-drm-i915-extend-audio-CDCLK-2-BCLK-constraint-to-mor.patch
+ patch -p1 -i ../0010-drm-i915-Limit-audio-CDCLK-2-BCLK-constraint-back-to.patch
+ patch -p1 -i ../0011-pinctrl-sunrisepoint-Add-missing-Interrupt-Status-re.patch
+ patch -p1 -i ../0012-Revert-iwlwifi-mvm-fix-scan-config-command-size.patch
+ patch -p1 -i ../0013-e1000e-Revert-e1000e-Make-watchdog-use-delayed-work.patch
+ patch -p1 -i ../0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch
+ patch -p1 -i ../0015-ptp-free-ptp-device-pin-descriptors-properly.patch
+
# fix naming schema in EXTRAVERSION of ck patch set
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}"
# ck patch
- msg2 "Applying ck patch"
+ echo "Applying ck patch"
patch -F 3 -Np1 -i ../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}
# graysky gcc hotfixes
- msg2 "Applying graysky gcc patch hotfixes"
+ echo "Applying graysky gcc patch hotfixes"
patch -p1 -i ../graysky_bdver2-hotfix.patch "$srcdir/kernel_gcc_patch-${_gccpatchver}/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch"
# graysky gcc patch
- msg2 "Applying graysky cpu patch"
+ echo "Applying graysky cpu patch"
patch -p1 -i ../kernel_gcc_patch-${_gccpatchver}/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch
# Ignore ath9k eeprom patch
- msg2 "Applying ath9k patch"
+ echo "Applying ath9k patch"
patch -p1 -i ../ath9k-regdom-hack.patch
# Set default raid6 algo patch
- msg2 " Applying raid6 patch"
+ echo " Applying raid6 patch"
patch -p1 -i ../raid6-default-algo.patch
- msg2 "Setting version..."
+ echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- msg2 "Setting config..."
+ echo "Setting config..."
# we are in src/linux-x.yy.zz, looking for a config next to the pkgbuild
if [ -f ${SRCDEST}/config.ck.previous ]; then
cp ${SRCDEST}/config.ck.previous .config
@@ -162,7 +166,7 @@ prepare() {
make olddefconfig
if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Running make localmodconfig"
+ echo "Running make localmodconfig"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
fi
@@ -185,10 +189,10 @@ prepare() {
cat ../version.temp | tr -d "\n" > version
# back up the config
- msg2 "Backing up config..."
+ echo "Backing up config..."
cp .config ${SRCDEST}/config.ck.previous
- msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
+ echo "Prepared %s version %s" "$pkgbase" "$(<version)"
}
build() {
@@ -206,7 +210,7 @@ _package() {
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- msg2 "Installing boot image..."
+ echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
@@ -214,13 +218,13 @@ _package() {
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
- msg2 "Installing modules..."
+ echo "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -230,7 +234,7 @@ _package-headers() {
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- msg2 "Installing build files..."
+ echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
@@ -245,7 +249,7 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- msg2 "Installing headers..."
+ echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
@@ -261,10 +265,10 @@ _package-headers() {
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- msg2 "Installing KConfig files..."
+ echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
- msg2 "Removing unneeded architectures..."
+ echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
@@ -272,16 +276,16 @@ _package-headers() {
rm -r "$arch"
done
- msg2 "Removing documentation..."
+ echo "Removing documentation..."
rm -r "$builddir/Documentation"
- msg2 "Removing broken symlinks..."
+ echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
- msg2 "Removing loose objects..."
+ echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
- msg2 "Stripping build tools..."
+ echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -bi "$file")" in
@@ -296,11 +300,11 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- msg2 "Adding symlink..."
+ echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}