summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD89
1 files changed, 39 insertions, 50 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe85197..00a2813 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,18 +17,19 @@
# Arch version builds documentation
pkgbase=linux-ck
-_majver=5.2
-_minver=21
+_supver=5
+_majver=3
+_minver=7
if [ "$_minver" == "0" ]; then
- pkgver=${_majver}
+ pkgver=${_supver}.${_majver}
else
- pkgver=${_majver}.${_minver}
+ pkgver=${_supver}.${_majver}.${_minver}
fi
+_srcname=linux-${pkgver}
_ckpatchversion=ck1
-_ckpatch="patch-${_majver}-${_ckpatchversion}"
+_ckpatch="patch-${_supver}.${_majver}-${_ckpatchversion}"
_gccpatchver='20190822'
-_srcname=linux-${pkgver}
-pkgrel=1
+pkgrel=2
url='https://kernel.org'
#url='http://ck.kolivas.org/patches/'
arch=('x86_64')
@@ -39,9 +40,10 @@ makedepends=(
conflicts=('linux-libre')
options=('!strip')
source=(
- https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar.{xz,sign}
+ https://www.kernel.org/pub/linux/kernel/v${_supver}.x/linux-$pkgver.tar.{xz,sign}
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
- linux-ck-patch-${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-${_ckpatchversion}/${_ckpatch}.xz
+ 0002-Bluetooth-hidp-Fix-assumptions-on-the-return-value-of-hidp_send_message.patch
+ linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/${_ckpatch}.xz
graysky_bdver2-hotfix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
@@ -51,15 +53,16 @@ source=(
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('9a8ee3ff75dabffa76141c8dc7529dfbb3ca07888a3708a13f15b412268b3538'
+sha256sums=('c6c9714e21531c825c306b107bc6f6c7bfa2d5270a14bad170f8de5a73d34802'
'SKIP'
'e862ecd2cb0b20e1859ec3e47616457a9a3acb111cd5a86094f9ed1dbd7f42ac'
- 'f1abc13a8d859fbf6350040e45d7f04ad551a6d39f113ba96fbbd820118c0e36'
+ '9b92add42581aeb427a0c2cffc584815f0e4223a1a6bc27802ccd77eaf6e4bec'
+ '5b66761eae4efa4cb967aba9d4e555aa320cf5c004f0848e6bfbcb75ef66fbf1'
'c5405139aa0a90a6f68f6a13e066a2bd0600c970f9f525cd3aa114b044a7f73b'
'8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
'0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
- '2b2b5734042c314552658b9ddf35d9a9549065a76c08be5b773a9102ea8de0f5'
+ 'c90c450baccd563dc01829f03e71cfc4e1b8fb26a367838f4751a186c70a395f'
'452b8d4d71e1565ca91b1bebb280693549222ef51c47ba8964e411b2d461699c'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -69,6 +72,9 @@ validpgpkeys=(
)
_kernelname=${pkgbase#linux}
+#export KBUILD_BUILD_HOST=arc4linux
+export KBUILD_BUILD_USER=$pkgbase
+export KBUILD_BUILD_TIMESTAMP="@${SOURCE_DATE_EPOCH:-$(date +%s)}"
prepare() {
cd $_srcname
@@ -76,24 +82,25 @@ prepare() {
# add upstream patch
# if [ "$_minver" != "0" ]; then
# msg2 "Applying upstream patch"
-# patch -Np1 < ../patch-${_majver}-${_pkgver}
+# patch -Np1 < ../patch-${_supver}.${_majver}-${_pkgver}
# fi
# Hotfixes
msg2 "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
+ patch -p1 -i ../0002-Bluetooth-hidp-Fix-assumptions-on-the-return-value-of-hidp_send_message.patch
# fix naming schema in EXTRAVERSION of ck patch set
- sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../linux-ck-patch-${_majver}-${_ckpatchversion}"
+ sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}"
# fix ck1 patchset for 5.2.18
- sed -i -e '/^-CFLAGS/ s,+=,:=,' -i -e '/^+CFLAGS/ s,+=,:=,' ../"${_ckpatch}"
+ sed -i -e '/^-CFLAGS/ s,+=,:=,' -i -e '/^+CFLAGS/ s,+=,:=,' "../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}"
# ck patch
msg2 "Applying ck patch"
- patch -F 3 -Np1 -i ../linux-ck-patch-${_majver}-${_ckpatchversion}
+ patch -F 3 -Np1 -i ../linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}
# graysky gcc hotfixes
@@ -122,29 +129,22 @@ prepare() {
msg2 "Setting config..."
# we are in src/linux-x.yy.zz, looking for a config next to the pkgbuild
- if [ -f ${SRCDEST}/config.ck.previous ]; then
- cp ${SRCDEST}/config.ck.previous .config
- else
+# if [ -f ${SRCDEST}/config.ck.previous ]; then
+# cp ${SRCDEST}/config.ck.previous .config
+# else
cp ../config.x86_64 .config
- fi
-
- # https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
- sed -i -e 's/# CONFIG_PSI_DEFAULT_DISABLED is not set/CONFIG_PSI_DEFAULT_DISABLED=y/' ./.config
-
- # https://bbs.archlinux.org/viewtopic.php?pid=1863567#p1863567
- sed -i -e 's/CONFIG_LATENCYTOP=y/# CONFIG_LATENCYTOP is not set/' \
- -i -e 's/CONFIG_SCHED_DEBUG=y/# CONFIG_SCHED_DEBUG is not set/' ./.config
+# fi
make olddefconfig
- make menuconfig
+# make menuconfig
# Remove sublevel when no sublevel exists
if [ "$_minver" == "0" ]; then
sed -i '/SUBLEVEL = 0/d' Makefile
fi
- make -s kernelrelease > ../version
+ make -s kernelrelease > version
# workaround for make -s kernelrelease not applying
# localversion to version when changed using menuconfig
@@ -153,13 +153,13 @@ prepare() {
cat "localversion.10-pkgrel" >> ../version.temp
cat "localversion.20-pkgname" >> ../version.temp
cat ../localversion >> ../version.temp
- cat ../version.temp | tr -d "\n" > ../version
+ cat ../version.temp | tr -d "\n" > version
# back up the config
- msg2 "Backing up config..."
- cp .config ${SRCDEST}/config.ck.previous
+# msg2 "Backing up config..."
+# cp .config ${SRCDEST}/config.ck.previous
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
}
build() {
@@ -175,11 +175,11 @@ _package() {
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
+ cd $_srcname
+
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- cd $_srcname
-
msg2 "Installing boot image..."
install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
@@ -190,13 +190,6 @@ _package() {
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # a place for external modules,
- # with version file for building modules and running depmod from hook
- local extramodules="extramodules$_kernelname"
- local extradir="$pkgdir/usr/lib/modules/$extramodules"
- install -Dt "$extradir" -m644 ../version
- ln -sr "$extradir" "$modulesdir/extramodules"
-
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -205,7 +198,6 @@ _package() {
local subst="
s|%PKGBASE%|$pkgbase|g
s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extramodules|g
"
# hack to allow specifying an initially nonexisting install file
@@ -227,12 +219,12 @@ _package() {
_package-headers() {
pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
msg2 "Installing build files..."
- install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -245,9 +237,6 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- # ???
- mkdir "$builddir/.tmp_versions"
-
msg2 "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
@@ -301,7 +290,7 @@ _package-headers() {
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
- ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"