summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 19 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d06fed..86825d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@
pkgbase=linux-ck
_supver=5
_majver=5
-_minver=6
+_minver=7
_gccpatchver='20191217'
_gccpatchger='9.1'
_gccpatchker='5.5'
@@ -46,16 +46,14 @@ source=(
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch
- 0004-drm-i915-Wean-off-drm_pci_alloc-drm_pci_free.patch
- 0005-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
- 0006-drm-i915-execlists-Always-force-a-context-reload-whe.patch
- 0007-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
- 0008-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
- 0009-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
- 0010-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
- 0011-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
- 0012-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
- 0013-drm-i915-Introduce-a-vma.kref.patch
+ 0004-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
+ 0005-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
+ 0006-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
+ 0007-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
+ 0008-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
+ 0009-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
+ 0010-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
+ 0011-drm-i915-Introduce-a-vma.kref.patch
linux-ck-patch-${_supver}.${_majver}-${_ckpatchversion}.xz::http://ck.kolivas.org/patches/${_supver}.0/${_supver}.${_majver}/${_supver}.${_majver}-${_ckpatchversion}/patch-${_supver}.${_majver}-${_ckpatchversion}.xz
graysky_bdver2-hotfix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
@@ -68,14 +66,12 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
-b2sums=('5af861196e6365c4ca00f658d8128455f0eb00cfd98ca7f7b37dcf5c962dd332f2a12b29a4bd0d13463c09573ccb97993129736dd2464bc03305583974546ab1'
+b2sums=('25a0c09a2a8b2ff8762dcf29dc326339537a49996b232c1568de036475a3afb62406fcf85c4357a8fa32088fdb7f868c46ff13a6fa3c2c554b8717c7fbe57712'
'SKIP'
'ab1fb19c67d4c107f75767581c33d9c1458b4d9fdb88f4adb41d30a36f5a2f95f1c48ef079eb87e1e6e8ce2f98b293195cb2c0f2a8ec975aa817453289158c6e'
'2e822cf7d4ff8b7458e22d3ce110fd8534e17a9aac2feace41c591f70697e1fab7bd9ce307c60a6361fbe525d10dab74c8b76fcb5276cd27f6e945f8fdfcc25c'
'1ae8107eb3d56db5b61fa07a35181232cc0be6c66f10b313a2f6b473bdbb33a42d8be3660413eef5321e08a775cda47260775174f74b803f3e66cdb890b9c6f3'
- '6018d823c70f6129b8b52c77f9308e90a83de575f2206a056d562469f227e7651815ff4ed9be484409ea2a109eb6743fb0c71067f237d714934bd02ea132973e'
'd8027cd96a447ea0987a67f3e65d157bb3d396069a944b140610f74c663677fe45e171e96a92dfd5eda8f71a5c715fd8114ee0e60b7620bc401a2a548bcf83cc'
- '2d8579a1d27a0a40866b4f7f5c63ad5e402d919e21d09faf4cec14f3b19b8fc42b6fc3cb8d26dce3100a9e63ca21ab01519a0e804f34c35e4bda154fbe725602'
'df41200d86f1fd493861d4b4a091ec5f853ce7668ec9712f57e574ce2c1a94c7054ec8abcdf947086e5f98b0cdde73523521552536c91373dacdd10c4ecf4c1a'
'f4d5f82c5deb981f475fd18a408e23b5f170e23c7a49c3563171e55abd78c07c475a7a9c67850c4a3665ce3447cd7b5fb3171e47af8cd8077822f2a6679cfd9b'
'70d02b7fc8b26c783eaabafb9bef5d3895c0031642dc8b71d8737762722695221340315576433d1544b79b37446212ce5e3d0936f695af307b3344a717274ba8'
@@ -88,7 +84,7 @@ b2sums=('5af861196e6365c4ca00f658d8128455f0eb00cfd98ca7f7b37dcf5c962dd332f2a12b2
'd76bd0bf237ea2bb7999fd3715cb664d89148cb0ade8057d57cdb40bc0a7954336e50ee077312e5e192398b0f35f055786deb98af9130d57e60f2ea040fbb66f'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
- 'ed087b05d12bf5fcec63914e19e70f0caed5892645c0a35819f1b12a48b4e78236ebf060de4ed03eb20210182510d1e95385cdfcde6fe72d1c55db59c3f8968e')
+ '45f839ec4a1eb901e348d63c52f2c9b80c430d4a1885dff86ffb81eec2e10a7c8863e5b361e37d09e05aa2b20154978026306b3340f36c74c77daa7f2273c342')
#export KBUILD_BUILD_HOST=arc4linux
export KBUILD_BUILD_USER=$pkgbase
@@ -109,16 +105,14 @@ prepare() {
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
patch -p1 -i ../0002-iwlwifi-pcie-restore-support-for-Killer-Qu-C0-NICs.patch
patch -p1 -i ../0003-iwlwifi-mvm-Do-not-require-PHY_SKU-NVM-section-for-3.patch
- patch -p1 -i ../0004-drm-i915-Wean-off-drm_pci_alloc-drm_pci_free.patch
- patch -p1 -i ../0005-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
- patch -p1 -i ../0006-drm-i915-execlists-Always-force-a-context-reload-whe.patch
- patch -p1 -i ../0007-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
- patch -p1 -i ../0008-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
- patch -p1 -i ../0009-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
- patch -p1 -i ../0010-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
- patch -p1 -i ../0011-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
- patch -p1 -i ../0012-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
- patch -p1 -i ../0013-drm-i915-Introduce-a-vma.kref.patch
+ patch -p1 -i ../0004-drm-Remove-PageReserved-manipulation-from-drm_pci_al.patch
+ patch -p1 -i ../0005-drm_915_Serialise_i915_active_acquire_with__active_retire.patch
+ patch -p1 -i ../0006-drm_i915_gem_Take_runtime-pm_wakeref_prior_to_unbinding.patch
+ patch -p1 -i ../0007-drm-915-gem-Avoid-parking-the-vma-as-we-unbind.patch
+ patch -p1 -i ../0008-drm-i915-gem-Try-to-flush-pending-unbind-events.patch
+ patch -p1 -i ../0009-drm-i915-gem-Reinitialise-the-local-list-before-repeating.patch
+ patch -p1 -i ../0010-drm-i915-Add-a-simple-is-bound-check-before-unbinding.patch
+ patch -p1 -i ../0011-drm-i915-Introduce-a-vma.kref.patch
# fix naming schema in EXTRAVERSION of ck patch set