aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 14 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index a4b0c6e..42f0a8b 100644
--- a/meson.build
+++ b/meson.build
@@ -1,13 +1,24 @@
project('rcc', [],
- version: '0.1.0',
+ version: '0.1.1',
license: 'BSD-2-Clause',
)
prog_python = import('python').find_installation('python3')
-rcc = generator(prog_python,
+rcc_generator = generator(prog_python,
output: '@BASENAME@.h',
arguments: [ meson.current_source_dir()/'rcc', '--output=@OUTPUT@', '@EXTRA_ARGS@', '@INPUT@' ]
)
+rcc_exe = files('rcc')
+
# example usage:
-#rcc.process(files('res/a.svg'), extra_args: [ '--namespace=svg', 'dump' ])
+
+# Dump multiple files into their own header
+#rcc_generator.process(files('a.svg', 'b.svg', 'c.svg'), extra_args: ['dump', '-ns=svg'])
+
+# Dump all the files into a single header
+#dump_h = custom_target('dump_h',
+# input: files('a.svg', 'b.svg', 'c.svg'),
+# output: 'dump.h',
+# command: [ python3, rcc_exe, '-o=@OUTPUT@', 'dump', '-ns=dump', '@INPUT@' ]
+#)