summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristophe Giboudeaux <cgiboudeaux@gmx.com>2011-10-26 11:28:35 +0200
committerChristophe Giboudeaux <cgiboudeaux@gmx.com>2011-10-26 11:28:35 +0200
commitea9b3661dab69cc23717dda88aee08749afa9383 (patch)
treeb8d23a7c263dc97c2b838b3b25861b9be33ed1ed /CMakeLists.txt
parentrekonq 0.8.51 (diff)
downloadrekonq-ea9b3661dab69cc23717dda88aee08749afa9383.tar.xz
Decrease the minimum Qt version and use pkgconfig to find the QtWebkit one.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e00ecb8d..fe562612 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,17 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.6.4)
# ==================================================================================
-FIND_PACKAGE(Qt4 4.8.0 COMPONENTS QtCore QtGui QtNetwork QtWebKit REQUIRED)
+FIND_PACKAGE(Qt4 4.7.0 COMPONENTS QtCore QtGui QtNetwork QtWebKit REQUIRED)
+
+# Ensure we have QtWebKit >=2.2.0
+FIND_PACKAGE(PkgConfig REQUIRED)
+PKG_CHECK_MODULES(PC_QTWEBKIT QUIET QtWebKit>=4.9.0)
+IF(NOT PC_QTWEBKIT_FOUND)
+ MESSAGE(FATAL_ERROR "QtWebkit 2.2.0 is required for this version of Rekonq")
+ELSE()
+ MESSAGE(STATUS "Found QtWebKit ${PC_QTWEBKIT_VERSION}")
+ENDIF()
+
FIND_PACKAGE(KDE4 4.6.90 REQUIRED)
INCLUDE(MacroOptionalFindPackage)