summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2012-04-20 06:09:35 +0200
committerAndrea Diamantini <adjam7@gmail.com>2012-04-20 06:09:35 +0200
commit98b94925b44aa0a228c43dfb54a449a737d144a6 (patch)
treec0687703d3e390a8622aeaafdc4c43d1e2b1ec29 /CMakeLists.txt
parentFix apturl handling (workaround) (diff)
downloadrekonq-98b94925b44aa0a228c43dfb54a449a737d144a6.tar.xz
master no more compiles with qt 4.7.x. Setting min qt to 4.8.x
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 12 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae4f3308..e1967fb9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,18 +21,18 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.6.4)
# ==================================================================================
-FIND_PACKAGE(Qt4 4.7.0 COMPONENTS QtCore QtGui QtNetwork REQUIRED)
-
-# Ensure we have QtWebKit >= 2.2.0
-FIND_PACKAGE(PkgConfig REQUIRED)
-PKG_CHECK_MODULES(PC_QTWEBKIT REQUIRED QtWebKit>=4.8.0)
-IF(NOT PC_QTWEBKIT_FOUND)
- MESSAGE(FATAL_ERROR "QtWebkit 2.2.0 is required for this version of Rekonq")
-ELSE()
- MESSAGE(STATUS "Found QtWebKit ${PC_QTWEBKIT_VERSION}")
-ENDIF()
-
-FIND_PACKAGE(KDE4 4.6.90 REQUIRED)
+FIND_PACKAGE(Qt4 4.8.0 COMPONENTS QtCore QtGui QtNetwork QtWebKit REQUIRED)
+
+## Ensure we have QtWebKit >= 2.2.0
+#FIND_PACKAGE(PkgConfig REQUIRED)
+#PKG_CHECK_MODULES(PC_QTWEBKIT REQUIRED QtWebKit>=4.8.0)
+#IF(NOT PC_QTWEBKIT_FOUND)
+# MESSAGE(FATAL_ERROR "QtWebkit 2.2.0 is required for this version of Rekonq")
+#ELSE()
+# MESSAGE(STATUS "Found QtWebKit ${PC_QTWEBKIT_VERSION}")
+#ENDIF()
+
+FIND_PACKAGE(KDE4 4.7.0 REQUIRED)
INCLUDE(MacroOptionalFindPackage)
INCLUDE(FindPackageHandleStandardArgs)