summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2022-08-15 17:30:11 +0300
committeraqua <aqua@iserlohn-fortress.net>2022-08-15 17:30:11 +0300
commit5a9617e76e7c987016cb1f4189908f8430777f3e (patch)
treea997c4a6233d3ee02cb330e48d448f2e25bddd43 /CMakeLists.txt
parentRecord authors and contributors in src/data/about.html (diff)
downloadrekonq-5a9617e76e7c987016cb1f4189908f8430777f3e.tar.xz
Add third-party/SingleApplication
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d551f8d..b9433e45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,11 @@ if(TESTING)
endif()
# ==================================================================================
+# third-party requirements
+set(QAPPLICATION_CLASS QApplication CACHE STRING "Inheritance class for SingleApplication")
+add_subdirectory(third-party/SingleApplication)
+
+# ==================================================================================
# optional nepomuk requirements
if(WITH_NEPOMUK)