summaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2009-09-08 02:38:18 +0200
committerAndrea Diamantini <adjam7@gmail.com>2009-09-10 22:15:10 +0200
commit667bd0a8450835f9b95b8ce83fb4f04a7df6d4ca (patch)
treea202cb184a88313c24c407d94d5c3147d144a57e /data/CMakeLists.txt
parentrekonq 0.2.56 with session management (recover on crash) (diff)
downloadrekonq-667bd0a8450835f9b95b8ce83fb4f04a7df6d4ca.tar.xz
HUGE HUGE HUGE COMMIT!
First implementation of "rekonq home page" - Added icons && htmls for it - fixed pics places && CMakeLists.txt - Added a HomePage class to create the "rekonq home Page" - Modified setting to load on new tab start 1) rekonq home page (default) 2) blank page 3) an url (to set) - removed home page button - fixed WebPage && loadUrl slot to load "home:" scheme - Added a toolbar method in BookmarksProvider to load bookmarks in the homepage The page needs a lot of love, but I think this is a really good starting point for. Hope you like it :)
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 93b9f83c..062bc138 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -1,5 +1,5 @@
INSTALL(
- FILES loading.mng
+ FILES closed.png loading.mng open.png webkit-icon.png
DESTINATION ${DATA_INSTALL_DIR}/rekonq/pics
)
@@ -14,11 +14,6 @@ INSTALL(
)
INSTALL(
- FILES notfound.html
+ FILES notfound.html home.html
DESTINATION ${DATA_INSTALL_DIR}/rekonq/htmls
)
-
-INSTALL(
- FILES webkit-icon.png
- DESTINATION ${DATA_INSTALL_DIR}/rekonq/pics
-)