summaryrefslogtreecommitdiff
path: root/kwebapp/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2011-11-08 10:17:36 +0100
committerAndrea Diamantini <adjam7@gmail.com>2011-11-08 10:17:36 +0100
commit7187da9812bbe6ffb5bf272f18f8e74c8d23d3c7 (patch)
tree210924711005452a622383dcfadb20c5c4cfb364 /kwebapp/CMakeLists.txt
parentLet rekonq save file remotely (diff)
downloadrekonq-7187da9812bbe6ffb5bf272f18f8e74c8d23d3c7.tar.xz
Application Shortcut
Added an action to manage it in the tools menu, added initial code to manage icons, added kwebapp application
Diffstat (limited to 'kwebapp/CMakeLists.txt')
-rw-r--r--kwebapp/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/kwebapp/CMakeLists.txt b/kwebapp/CMakeLists.txt
new file mode 100644
index 00000000..dda4616d
--- /dev/null
+++ b/kwebapp/CMakeLists.txt
@@ -0,0 +1,24 @@
+set( kwebapp_SRCS
+ webview.cpp
+ webpage.cpp
+ kwebmain.cpp
+ )
+
+include_directories ( ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${QT4_INCLUDES}
+ ${KDE4_INCLUDES}
+
+)
+
+
+kde4_add_executable(kwebapp ${kwebapp_SRCS})
+
+target_link_libraries(kwebapp
+ ${KDE4_KDEUI_LIBS}
+ ${KDE4_KDEWEBKIT_LIBS}
+)
+
+
+install(TARGETS kwebapp ${INSTALL_TARGETS_DEFAULT_ARGS} )
+