summaryrefslogtreecommitdiff
path: root/plugins/webengine/CMakeLists.txt
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2022-08-25 21:30:08 +0300
committeraqua <aqua@iserlohn-fortress.net>2022-08-27 08:52:19 +0300
commit8f992bb6ff8a1995ed757edf39578c986ef700fc (patch)
treea45ce632366fb8daefcb8847d16d762e1219550b /plugins/webengine/CMakeLists.txt
parentAdd scripts/check_license.py (diff)
downloadrekonq-8f992bb6ff8a1995ed757edf39578c986ef700fc.tar.xz
Add CMakePresets.json
- add clang-tidy to debug configuration - add valgrind target: test_memcheck - add coverage target: test_coverage - bitbucket pipelines: store test results in junit format for test reporting
Diffstat (limited to 'plugins/webengine/CMakeLists.txt')
-rw-r--r--plugins/webengine/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/webengine/CMakeLists.txt b/plugins/webengine/CMakeLists.txt
index 8a11bc76..f49d9c7c 100644
--- a/plugins/webengine/CMakeLists.txt
+++ b/plugins/webengine/CMakeLists.txt
@@ -7,6 +7,6 @@ add_library(WebEnginePlugin MODULE
target_include_directories(WebEnginePlugin PRIVATE ${PROJECT_SOURCE_DIR}/src/plugins)
target_link_libraries(WebEnginePlugin PUBLIC Qt6::Core Qt6::WebEngineWidgets)
-if(TESTING)
+if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
add_test(NAME "load_plugin WebEnginePlugin" COMMAND load_plugin $<TARGET_FILE:WebEnginePlugin>)
endif()