summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2011-02-01 17:32:57 +0100
committerAndrea Diamantini <adjam7@gmail.com>2011-02-01 17:32:57 +0100
commit7a1aaf4d1e86d45691e981e92d99a817849240fd (patch)
tree1cadcb489da6f17a81c63989a25e2076e7899e49 /src/CMakeLists.txt
parentIf a cached suggestion is older than one week, it is downloaded again, allowi... (diff)
downloadrekonq-7a1aaf4d1e86d45691e981e92d99a817849240fd.tar.xz
User Agent Switcher.
This patch should implement the UA switcher ability for rekonq. This is a first implementation, but it seems working quite well. It is based on KDE UA management and should be fully compatible with konqueror's one i.e. it should be possible using alternatively rekonq and konqueror sharing the same setting. Anyway, this is a different implementation from the konqueror's one. Simpler and based on the idea of a future moving to a plugin.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6cf26517..7f9fe19f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -81,6 +81,9 @@ SET( rekonq_KDEINIT_SRCS
opensearch/opensearchmanager.cpp
opensearch/opensearchengine.cpp
opensearch/suggestionparser.cpp
+ #----------------------------------------
+ useragent/useragentinfo.cpp
+ useragent/useragentwidget.cpp
)
@@ -91,6 +94,7 @@ KDE4_ADD_UI_FILES( rekonq_KDEINIT_SRCS
settings/settings_webkit.ui
settings/settings_adblock.ui
cleardata.ui
+ useragent/useragentsettings.ui
)
KDE4_ADD_KCFG_FILES( rekonq_KDEINIT_SRCS rekonq.kcfgc )
@@ -107,6 +111,7 @@ INCLUDE_DIRECTORIES ( ${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/rekonqpage
${CMAKE_CURRENT_SOURCE_DIR}/settings
${CMAKE_CURRENT_SOURCE_DIR}/urlbar
+ ${CMAKE_CURRENT_SOURCE_DIR}/useragent
${CMAKE_CURRENT_BINARY_DIR}
${KDE4_INCLUDES}
${QT4_INCLUDES}