summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2010-04-05 01:31:13 +0200
committerAndrea Diamantini <adjam7@gmail.com>2010-04-05 01:31:13 +0200
commit352168759ea96b35296eaf33790fbe073b69f69b (patch)
treef30a483162d84101b142825823872e64489620ce /src/CMakeLists.txt
parentA "nice" hack to fix bug 211557 (diff)
downloadrekonq-352168759ea96b35296eaf33790fbe073b69f69b.tar.xz
This commit is the first implementation of a new new new urlbar
Here are its features: - KLineEdit based - ability to easily add "icons" :) - SSL informations shown (a-la firefox) - smoother animation - cleaner code - data QString, not KUrl based (Users type string, not urls!!!)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a68faa59..8728bff8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -49,6 +49,7 @@ SET( rekonq_KDEINIT_SRCS
#----------------------------------------
urlbar/urlbar.cpp
urlbar/lineedit.cpp
+ urlbar/iconbutton.cpp
urlbar/completionwidget.cpp
urlbar/urlresolver.cpp
urlbar/listitem.cpp