summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSiteshwar Vashisht <siteshwar@gmail.com>2012-04-23 01:18:01 +0200
committerAndrea Diamantini <adjam7@gmail.com>2012-04-23 01:46:11 +0200
commitcd6eee46a7405bc2365ada5ca7cd2daab01e06c0 (patch)
treef9c35fedba651e15fa2550804bcd9261c5aa1a91 /src/CMakeLists.txt
parentFix opensearch add shortcut handling (diff)
downloadrekonq-cd6eee46a7405bc2365ada5ca7cd2daab01e06c0.tar.xz
Google Sync Bookmarks in rekonq!
- Added UI bits to configure Google Bookamrks Sync - Implemented sync, 2-way merging local and remote bk - Remember to not update local history while remotely adding bookmarks - Encode parameters of add bookmarks request while posting data. - (adjam) fix compile warnings This is the squashed commit of Situ's work on Google Bookmarks Sync SQUASHED BY: adjam ;) REVIEW: 104673 DIGEST: Google Bookmarks Sync REVIEWED BY: adjam
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ac4fa87b..1180ad0d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -99,6 +99,7 @@ SET( rekonq_KDEINIT_SRCS
useragent/useragentwidget.cpp
#----------------------------------------
sync/ftpsynchandler.cpp
+ sync/googlesynchandler.cpp
sync/syncassistant.cpp
sync/synchandler.cpp
sync/syncmanager.cpp
@@ -107,6 +108,7 @@ SET( rekonq_KDEINIT_SRCS
sync/syncdatawidget.cpp
sync/synchosttypewidget.cpp
sync/syncftpsettingswidget.cpp
+ sync/syncgooglesettingswidget.cpp
)
@@ -130,6 +132,7 @@ KDE4_ADD_UI_FILES( rekonq_KDEINIT_SRCS
sync/sync_check.ui
sync/sync_data.ui
sync/sync_ftp_settings.ui
+ sync/sync_google_settings.ui
sync/sync_host_type.ui
)