summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2010-03-13 23:24:45 +0100
committerAndrea Diamantini <adjam7@gmail.com>2010-03-13 23:24:45 +0100
commit6faa12680a0d7d2f13c2862628325ab65521004b (patch)
treed749f40b304feb6c1d007dcce46c9c8e9d17932d /src/CMakeLists.txt
parentUpdating forgotten files (diff)
downloadrekonq-6faa12680a0d7d2f13c2862628325ab65521004b.tar.xz
Implemented automatic adblock update.
This (squashed) commit adds this new feature in rekonq, letting people to simply "forgot" adblock and let rekonq do everything for it I added: - a new (rekonq) adblock widget - an asyncronous method to update rules from the net every TOT days - a better AdBlockManager management. What it is actually missing is the adp protocol support to add new subscriptions to adblock. This will come the next week. For now this part seems stable and needs just testing :)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 00cfbf77..f05bbbdb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -34,6 +34,7 @@ SET( rekonq_KDEINIT_SRCS
rekonqpage/previewselectorbar.cpp
#----------------------------------------
settings/settingsdialog.cpp
+ settings/adblockwidget.cpp
#----------------------------------------
bookmarks/bookmarksmanager.cpp
bookmarks/bookmarkspanel.cpp
@@ -54,6 +55,7 @@ KDE4_ADD_UI_FILES( rekonq_KDEINIT_SRCS
settings/settings_tabs.ui
settings/settings_fonts.ui
settings/settings_webkit.ui
+ settings/settings_adblock.ui
cleardata.ui
)