summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Poulain <benjamin.poulain@nokia.com>2010-08-18 04:44:22 +0200
committerBenjamin Poulain <benjamin.poulain@nokia.com>2010-08-18 05:04:39 +0200
commit95c71246916f0986101f08ee362429b505cbcd3d (patch)
tree36009aaacd3c83baf288e5019a097c3c24a0212c /src/CMakeLists.txt
parentSplit AdBlock rule in two classes to move the implementation out of it (diff)
downloadrekonq-95c71246916f0986101f08ee362429b505cbcd3d.tar.xz
Add a primitive text machter as an AdBlockRule implementations
About 30% of the filter of easylist are just simple text matching. This new AdBlockRule implementation detects the simple occurences of this to match the url directly. On Qt 4.7, this reduce the time spend in AdBlock by around 20%.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8f4ac651..127c1c4f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -54,6 +54,7 @@ SET( rekonq_KDEINIT_SRCS
adblock/adblocknetworkreply.cpp
adblock/adblockrule.cpp
adblock/adblockrulefallbackimpl.cpp
+ adblock/adblockruletextmatchimpl.cpp
#----------------------------------------
urlbar/stackedurlbar.cpp
urlbar/urlbar.cpp