summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Poulain <benjamin.poulain@nokia.com>2010-08-19 02:26:40 +0200
committerBenjamin Poulain <benjamin.poulain@nokia.com>2010-08-19 03:18:29 +0200
commita4631fb9ec2541f99e1aba05cf1e7d2b5ebecb98 (patch)
tree2db557fe27ed8589eb0937755cf9bbe69dc1b1e5 /src/CMakeLists.txt
parentImprove the performance of AdBlockRuleTextMatchImpl (diff)
downloadrekonq-a4631fb9ec2541f99e1aba05cf1e7d2b5ebecb98.tar.xz
Add a special matcher for ad block filters for host name
Quite a few rules of ad block are just matching domains. Those are of the form: ||trolltech.com^$options This patch add a new class to deal with this kind of filter, AdBlockHostMatcher. Matching a host address is much faster (O(1)) than going through the entire list of rules.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dd90fc10..e873052b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -50,6 +50,7 @@ SET( rekonq_KDEINIT_SRCS
bookmarks/bookmarksproxy.cpp
bookmarks/bookmarkcontextmenu.cpp
#----------------------------------------
+ adblock/adblockhostmatcher.cpp
adblock/adblockmanager.cpp
adblock/adblocknetworkreply.cpp
adblock/adblockrule.cpp