summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2022-08-23 10:28:54 +0300
committeraqua <aqua@iserlohn-fortress.net>2022-09-05 23:07:42 +0300
commitfcd11edde50d65f272cfc1ebf211697d778af77e (patch)
tree225b1aeb2245dbdb1da018a6bf01c06c7e2d3869 /src/CMakeLists.txt
parentAdd UrlBar and TabBar (diff)
downloadrekonq-fcd11edde50d65f272cfc1ebf211697d778af77e.tar.xz
Add RekonqView_fake class
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d46537e9..75905f36 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -19,6 +19,9 @@ set(rekonq_SRCS
plugins/rplugininterface.hpp
#----------------------------------------
)
+if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+ list(APPEND rekonq_SRCS test/rview_fake.cpp test/rview_fake.h test/rview_fake.ui)
+endif()
list(TRANSFORM rekonq_SRCS PREPEND src/)
set(rekonq_SRCS ${rekonq_SRCS} PARENT_SCOPE)