summaryrefslogtreecommitdiff
path: root/src/adblock/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2009-11-23 03:11:26 +0100
committerAndrea Diamantini <adjam7@gmail.com>2009-11-23 03:11:26 +0100
commitdf7a2820a54d8b69e87b495269b88f9ae5ac156d (patch)
tree4124db211bddf2dbf784d0eddbf70bbb8c24ee0f /src/adblock/CMakeLists.txt
parentFixing urlbar size (diff)
parentSaving 4 bytes per tab :) (diff)
downloadrekonq-df7a2820a54d8b69e87b495269b88f9ae5ac156d.tar.xz
Merge branch 'devAdBlock'
Diffstat (limited to 'src/adblock/CMakeLists.txt')
-rw-r--r--src/adblock/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/adblock/CMakeLists.txt b/src/adblock/CMakeLists.txt
new file mode 100644
index 00000000..f2785811
--- /dev/null
+++ b/src/adblock/CMakeLists.txt
@@ -0,0 +1,21 @@
+
+ADD_DEFINITIONS ( ${KDE4_DEFINITIONS} )
+
+SET(kcm_webkitadblock_SRCS
+ kcmwebkitadblock.cpp
+)
+
+kde4_add_ui_files(kcm_webkitadblock_SRCS
+ webkitadblock.ui
+)
+
+kde4_add_plugin(kcm_webkitadblock ${kcm_webkitadblock_SRCS})
+
+target_link_libraries(kcm_webkitadblock
+ ${KDE4_KDEUI_LIBS}
+ ${KDE4_KIO_LIBS}
+)
+
+install(TARGETS kcm_webkitadblock DESTINATION ${PLUGIN_INSTALL_DIR} )
+
+install( FILES webkitAdblock.desktop DESTINATION ${SERVICES_INSTALL_DIR} )