summaryrefslogtreecommitdiff
path: root/src/adblock/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2009-11-20 14:59:55 +0100
committerAndrea Diamantini <adjam7@gmail.com>2009-11-20 14:59:55 +0100
commit770f38f4aced1656fdee3c6d0dcf8ddfb9493c2b (patch)
tree912660936d8a46bb88bfca38085741e270f70ce1 /src/adblock/CMakeLists.txt
parentAdBlock. First blocks :D (diff)
downloadrekonq-770f38f4aced1656fdee3c6d0dcf8ddfb9493c2b.tar.xz
AdBlock, first file (and first UI. Probably not last :)
Diffstat (limited to 'src/adblock/CMakeLists.txt')
-rw-r--r--src/adblock/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/adblock/CMakeLists.txt b/src/adblock/CMakeLists.txt
new file mode 100644
index 00000000..8777bc50
--- /dev/null
+++ b/src/adblock/CMakeLists.txt
@@ -0,0 +1,18 @@
+
+ADD_DEFINITIONS ( ${KDE4_DEFINITIONS} )
+
+SET(kcm_webkitadblock_SRCS
+ kcmwebkitadblock.cpp
+)
+
+kde4_add_ui_files(kcm_webkitadblock_SRCS
+ webkitadblock.ui
+)
+
+kde4_add_plugin(kcm_webkitadblock ${kcm_webkitadblock_SRCS})
+
+target_link_libraries(kcm_webkitadblock ${KDE4_KDEUI_LIBS} )
+
+install(TARGETS kcm_webkitadblock DESTINATION ${PLUGIN_INSTALL_DIR} )
+
+install( FILES webkitAdblock.desktop DESTINATION ${SERVICES_INSTALL_DIR} )