summaryrefslogtreecommitdiff
path: root/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Diamantini <adjam7@gmail.com>2010-04-20 16:43:10 +0200
committerAndrea Diamantini <adjam7@gmail.com>2010-04-20 16:43:10 +0200
commita708a0e447af81412599ec16e8d47e06dc584eb0 (patch)
tree1f717846b99d08141d15e13a644197058ce6070b /src/tests/CMakeLists.txt
parentReverting the switch case to an if-else one. (diff)
downloadrekonq-a708a0e447af81412599ec16e8d47e06dc584eb0.tar.xz
New (empty) urlbar test and improved protocolhandler test
Diffstat (limited to 'src/tests/CMakeLists.txt')
-rw-r--r--src/tests/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
index e05a056b..3bc9a27f 100644
--- a/src/tests/CMakeLists.txt
+++ b/src/tests/CMakeLists.txt
@@ -7,7 +7,6 @@ INCLUDE_DIRECTORIES ( ${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/../adblock
${CMAKE_CURRENT_SOURCE_DIR}/../bookmarks
${CMAKE_CURRENT_SOURCE_DIR}/../history
- ${CMAKE_CURRENT_SOURCE_DIR}/../rekonqpage
${CMAKE_CURRENT_SOURCE_DIR}/../settings
${CMAKE_CURRENT_SOURCE_DIR}/../urlbar
${KDE4_INCLUDES}
@@ -68,6 +67,7 @@ target_link_libraries( protocolhandler_test
${KDE4_KDECORE_LIBS}
${KDE4_KDEUI_LIBS}
${KDE4_KDEWEBKIT_LIBS}
+ ${QT_QTNETWORK_LIBRARY}
${QT_QTTEST_LIBRARY}
)
@@ -153,4 +153,16 @@ target_link_libraries( webview_test
${QT_QTTEST_LIBRARY}
)
+##### ------------- urlbar test
+
+kde4_add_unit_test( urlbar_test urlbar_test.cpp )
+
+target_link_libraries( urlbar_test
+ kdeinit_rekonq
+ ${KDE4_KDECORE_LIBS}
+ ${KDE4_KDEUI_LIBS}
+ ${KDE4_KDEWEBKIT_LIBS}
+ ${QT_QTTEST_LIBRARY}
+)
+
############################################################