summaryrefslogtreecommitdiff
path: root/kwebapp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kwebapp/CMakeLists.txt')
-rw-r--r--kwebapp/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/kwebapp/CMakeLists.txt b/kwebapp/CMakeLists.txt
new file mode 100644
index 00000000..dda4616d
--- /dev/null
+++ b/kwebapp/CMakeLists.txt
@@ -0,0 +1,24 @@
+set( kwebapp_SRCS
+ webview.cpp
+ webpage.cpp
+ kwebmain.cpp
+ )
+
+include_directories ( ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${QT4_INCLUDES}
+ ${KDE4_INCLUDES}
+
+)
+
+
+kde4_add_executable(kwebapp ${kwebapp_SRCS})
+
+target_link_libraries(kwebapp
+ ${KDE4_KDEUI_LIBS}
+ ${KDE4_KDEWEBKIT_LIBS}
+)
+
+
+install(TARGETS kwebapp ${INSTALL_TARGETS_DEFAULT_ARGS} )
+