summaryrefslogtreecommitdiff
path: root/src/bookmarks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/bookmarks/CMakeLists.txt')
-rw-r--r--src/bookmarks/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/bookmarks/CMakeLists.txt b/src/bookmarks/CMakeLists.txt
new file mode 100644
index 00000000..517aa2f6
--- /dev/null
+++ b/src/bookmarks/CMakeLists.txt
@@ -0,0 +1,22 @@
+add_library(bookmarks STATIC
+# bookmarkmanager.cpp bookmarkmanager.h
+# bookmarkowner.cpp bookmarkowner.h
+# bookmarkscontextmenu.cpp bookmarkscontextmenu.h
+# bookmarksmenu.cpp bookmarksmenu.h
+# bookmarkstoolbar.cpp bookmarkstoolbar.h
+ # Bookmarks Model
+ bookmarkstreeitem.cpp bookmarkstreeitem.hpp
+ bookmarkstreemodel.cpp bookmarkstreemodel.hpp
+ bookmarkstreeformats.hpp
+ bookmarkstreeformat_xbel_read.cpp bookmarkstreeformat_xbel_write.cpp
+ # Bookmark Manager
+ bookmarkmanager.cpp bookmarkmanager.hpp
+)
+target_include_directories(bookmarks PUBLIC ${CMAKE_SOURCE_DIR}/src)
+target_link_libraries(bookmarks PUBLIC Qt6::Core Qt6::Widgets)
+
+if(TESTING)
+ add_executable(xbel test/xbel.cpp)
+ target_link_libraries(xbel GTest::gtest GTest::gtest_main bookmarks)
+ gtest_discover_tests(xbel)
+endif()