summaryrefslogtreecommitdiff
path: root/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/CMakeLists.txt')
-rw-r--r--src/tests/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
new file mode 100644
index 00000000..9963acd4
--- /dev/null
+++ b/src/tests/CMakeLists.txt
@@ -0,0 +1,22 @@
+### ---------- General Settings -------
+
+SET( EXECUTABLE_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR} )
+
+INCLUDE_DIRECTORIES ( ${CMAKE_CURRENT_BINARY_DIR}/..
+ ${KDE4_INCLUDES}
+ ${QT4_INCLUDES}
+)
+
+##### -------------tabbar test
+
+kde4_add_unit_test( tabbar_test TEST tabbar_test.cpp )
+
+target_link_libraries( tabbar_test
+ kdeinit_rekonq
+ ${KDE4_KDECORE_LIBS}
+ ${KDE4_KDEUI_LIBS}
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTTEST_LIBRARY}
+)
+
+# --------------